Change in ovirt-engine[master]: webadmin: introduce NullableFrontendActionAsyncCallback
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: webadmin: introduce NullableFrontendActionAsyncCallback
......................................................................
webadmin: introduce NullableFrontendActionAsyncCallback
The methods Frontend#RunAction expect to receive an instance of
IFrontendActionAsyncCallback. but there are multiple places where the
result of the action isn't interesting. in those cases an instance of
empty IFrontendActionAsyncCallback is created and passed to those
methods.
This patch introduce Frontend#NULLABLE_ASYNC_CALLBACK which is an
instance of Frontend#NullableFrontendActionAsyncCallback that we can
passe to Frontend#RunAction methods instead.
Using NULLABLE_ASYNC_CALLBACK instead of creating new empty
implementation each time is better because:
1. the code is more readable as each creation of empty implementation of
the callback interface is composed on several lines in the code
2. the code is more efficient as we create less objects
Change-Id: Ic0cf37a9f4ffb973a3791323596af6d97c7365cb
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/Frontend.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/datacenters/DataCenterGuideModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/VmItemBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
6 files changed, 41 insertions(+), 92 deletions(-)
Approvals:
Tomas Jelinek: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11734
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic0cf37a9f4ffb973a3791323596af6d97c7365cb
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: userportal: wrong display type on run once
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: userportal: wrong display type on run once
......................................................................
userportal: wrong display type on run once
This patch solves a bug that when running a VM using 'run once' mode
from the user-portal, the VM is starting with its default display type
even though other display type was selected for it from the 'run once'
dialog.
This patch also fix the default selection of the display type in the
'run once' dialog of user-portal to be the default display type of the
VM (there was no default selection of display type in the dialog
before).
Change-Id: I665ab4578fea13fce6a22b77ee0c5d627b5c235b
Bug-Url: https://bugzilla.redhat.com/907776
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
1 file changed, 9 insertions(+), 0 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/11790
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I665ab4578fea13fce6a22b77ee0c5d627b5c235b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: host-deploy: use tar instead of python tarfile
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: host-deploy: use tar instead of python tarfile
......................................................................
host-deploy: use tar instead of python tarfile
python usage was introduced when fedora-18 alpha lacked tar
utility, now fedora-18 has tar utility and the python
implementation is too buggy. It does not treat trailing
zeros of tarfile correctly, causing the deployment to fail.
Change-Id: I9ece009af7d0c1800eb69b1ca99930892903fe9f
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11776
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9ece009af7d0c1800eb69b1ca99930892903fe9f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: core: Findbug fix of isPluggable method
by mkolesni@redhat.com
Mike Kolesnik has submitted this change and it was merged.
Change subject: core: Findbug fix of isPluggable method
......................................................................
core: Findbug fix of isPluggable method
This fixes an equals issue at isPluggable method
Change-Id: I4360ac7b3ccc02a3ec70e217bc7a1c3aa7d24301
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Mike Kolesnik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11784
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4360ac7b3ccc02a3ec70e217bc7a1c3aa7d24301
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
11 years, 10 months
Change in otopi[master]: core: aggregate correctly multi-value 'after'
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: core: aggregate correctly multi-value 'after'
......................................................................
core: aggregate correctly multi-value 'after'
Change-Id: I281b22f7cf128cb2dcc2350c725f3d649fa0f7bc
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M src/otopi/context.py
1 file changed, 5 insertions(+), 5 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11781
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I281b22f7cf128cb2dcc2350c725f3d649fa0f7bc
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in ovirt-host-deploy[master]: core: use before/after feature
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: core: use before/after feature
......................................................................
core: use before/after feature
Change-Id: I3ba635aa28c7c9c5047ea400de111dae2683fda8
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M src/plugins/ovirt-host-deploy/core/misc.py
M src/plugins/ovirt-host-deploy/core/offlinepackager.py
2 files changed, 8 insertions(+), 3 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11780
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3ba635aa28c7c9c5047ea400de111dae2683fda8
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-host-deploy
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in otopi[master]: core: use before/after feature
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: core: use before/after feature
......................................................................
core: use before/after feature
Change-Id: I8f377d454b2d1f3fed1bd4df6d98955258a8c64d
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M src/otopi/constants.py
M src/plugins/otopi/core/config.py
M src/plugins/otopi/core/log.py
M src/plugins/otopi/dialog/cli.py
M src/plugins/otopi/packagers/yumpackager.py
M src/plugins/otopi/services/openrc.py
M src/plugins/otopi/services/rhel.py
M src/plugins/otopi/services/systemd.py
M src/plugins/otopi/system/command.py
9 files changed, 36 insertions(+), 11 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11779
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8f377d454b2d1f3fed1bd4df6d98955258a8c64d
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in otopi[master]: core: context: support 'before', 'after' in sequence
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: core: context: support 'before', 'after' in sequence
......................................................................
core: context: support 'before', 'after' in sequence
Change-Id: Id560d4aac9052379442c43672d87153b2cb4aefa
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M README.API
M src/otopi/context.py
M src/otopi/plugin.py
3 files changed, 50 insertions(+), 3 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11778
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id560d4aac9052379442c43672d87153b2cb4aefa
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in otopi[master]: core: context: cleanup buildSequence
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: core: context: cleanup buildSequence
......................................................................
core: context: cleanup buildSequence
Change-Id: I31f95bc1331bc066e25b777a73b10c0ef84734b2
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M src/otopi/context.py
1 file changed, 19 insertions(+), 16 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11777
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I31f95bc1331bc066e25b777a73b10c0ef84734b2
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in ovirt-log-collector[master]: build: ovirt-log-collector-3.2.0_beta
by kroberts@redhat.com
Keith Robertson has submitted this change and it was merged.
Change subject: build: ovirt-log-collector-3.2.0_beta
......................................................................
build: ovirt-log-collector-3.2.0_beta
Change-Id: Ic62ba0e8ee17f65ca024066ee305dd72839c6c02
Signed-off-by: Kiril Nesenko <knesenko(a)redhat.com>
---
M configure.ac
M ovirt-log-collector.spec.in
2 files changed, 4 insertions(+), 2 deletions(-)
Approvals:
Alon Bar-Lev: Looks good to me, but someone else must approve
Keith Robertson: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/11769
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic62ba0e8ee17f65ca024066ee305dd72839c6c02
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Keith Robertson <kroberts(a)redhat.com>
11 years, 10 months