Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.2]: use vdsm to get storage path only for nfs
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: use vdsm to get storage path only for nfs
......................................................................
use vdsm to get storage path only for nfs
Change-Id: I3e9909ae70a1f3d5545c8c05ebc8b210a68ee642
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1150906
Signed-off-by: Jiri Moskovcak <jmoskovc(a)redhat.com>
(cherry picked from commit bb6326bedb7f1d9422245928fdc083b9f64c9608)
---
M ovirt_hosted_engine_ha/env/path.py
1 file changed, 11 insertions(+), 6 deletions(-)
Approvals:
Martin Sivák: Looks good to me, approved
Jiří Moskovčák: Verified
--
To view, visit http://gerrit.ovirt.org/33954
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3e9909ae70a1f3d5545c8c05ebc8b210a68ee642
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.2
Gerrit-Owner: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-hosted-engine-ha[master]: use vdsm to get storage path only for nfs
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: use vdsm to get storage path only for nfs
......................................................................
use vdsm to get storage path only for nfs
Change-Id: I3e9909ae70a1f3d5545c8c05ebc8b210a68ee642
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1150906
Signed-off-by: Jiri Moskovcak <jmoskovc(a)redhat.com>
---
M ovirt_hosted_engine_ha/env/path.py
1 file changed, 11 insertions(+), 6 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Martin Sivák: Looks good to me, approved
Jiří Moskovčák: Verified
--
To view, visit http://gerrit.ovirt.org/33952
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3e9909ae70a1f3d5545c8c05ebc8b210a68ee642
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine-sdk-java[master]: sdk: Add support for Kerberos authentication
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: sdk: Add support for Kerberos authentication
......................................................................
sdk: Add support for Kerberos authentication
This patch adds support for Kerberos authentication. To use it the user
must explicitly indicate it when creating the API object, for example:
Api api = new ApiBuilder()
.url("https://ovirt.example.com/ovirt-engine/api")
.kerberos(true)
.build();
When doing this the SDK will take the credentials from the Kerberos
credentials cache and will use them to authenticate with the server.
Note that the Kerberos environment has to be configured correctly before
calling the SDK and that the creditials cache has to be already
populated, using the "kinit" command, for example.
In order to configure the environment two files are needed: the Kerberos
configuration file and the JAAS configuration file. The Kerberos
configuration file will usually existin "/etc/krb5.conf". The JAAS
configuration file won't probably exist. It needs to be created with
content similar to this:
com.sun.security.jgss.login {
com.sun.security.auth.module.Krb5LoginModule required client=true useTicketCache=true;
};
com.sun.security.jgss.initiate {
com.sun.security.auth.module.Krb5LoginModule required client=true useTicketCache=true;
};
com.sun.security.jgss.accept {
com.sun.security.auth.module.Krb5LoginModule required client=true useTicketCache=true;
};
The location of this file isn't relevant, it just needs to be readable
by the JVM, it can be, for example, located in "/etc/jaas.conf".
In addition to these files the following system properties have to be
added to the JVM:
-Djava.security.auth.login.config=/etc/jaas.conf
-Djava.security.krb5.conf=/etc/krb5.conf
-Djavax.security.auth.useSubjectCredsOnly=false
Change-Id: Ide82e150a5b5b7e8ec9b83aa33c89f0c09656f99
Bug-Url: https://bugzilla.redhat.com/1145237
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M ovirt-engine-sdk-java-codegen/src/main/java/org/ovirt/engine/sdk/codegen/templates/ApiTemplate
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/Api.java
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/ApiBuilder.java
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/web/ConnectionsPoolBuilder.java
4 files changed, 141 insertions(+), 27 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/33504
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ide82e150a5b5b7e8ec9b83aa33c89f0c09656f99
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-java
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine-sdk-java[master]: sdk: Introduce ApiBuilder
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: sdk: Introduce ApiBuilder
......................................................................
sdk: Introduce ApiBuilder
Currently the Api class has a collection of constructor, with different
combinations as parameters. Using this constructors renders code that is
difficult to read, as many of the parameters are usually null. For
example, the call to create a SSL connection without server certificate
validation looks like this:
Api api = new Api(
"https://fedora.example.com:443/ovirt-engine/api",
"admin@internal",
"******",
null,
null,
null,
null,
true,
true,
false,
true
);
The nulls and the magic values in this type of call make it hard to
understand what it is really doing. To simplify this kind of calls this
patch introduces a new ApiBuilder class that can be used with a fluent
style. For example, for the same use case:
Api api = new ApiBuilder()
.url("https://fedora.example.com:443/ovirt-engine/api")
.user("admin@internal")
.password("******")
.noHostVerification(true)
.debug(true)
.build();
This is much easier to read.
Change-Id: I251070c8888046bfbac90c16306168318528b464
Related-To: https://bugzilla.redhat.com/1145237
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M ovirt-engine-sdk-java-codegen/src/main/java/org/ovirt/engine/sdk/codegen/templates/ApiTemplate
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/Api.java
A ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/ApiBuilder.java
M ovirt-engine-sdk-java/src/main/java/org/ovirt/engine/sdk/web/ConnectionsPoolBuilder.java
4 files changed, 604 insertions(+), 241 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/33503
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I251070c8888046bfbac90c16306168318528b464
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-java
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-hosted-engine-setup[master]: don't print stack trace when the ha broker is unreachable
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: don't print stack trace when the ha broker is unreachable
......................................................................
don't print stack trace when the ha broker is unreachable
Change-Id: I02cfcd2a59ede40efaa0747a7dd3b9758ffb5270
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1150073
Signed-off-by: Jiri Moskovcak <jmoskovc(a)redhat.com>
---
M src/ovirt_hosted_engine_setup/vm_status.py
1 file changed, 7 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Jiří Moskovčák: Verified
--
To view, visit http://gerrit.ovirt.org/33933
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I02cfcd2a59ede40efaa0747a7dd3b9758ffb5270
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: master
Gerrit-Owner: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: packaging: setup: removing 'Datacenter storage type' from th...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: packaging: setup: removing 'Datacenter storage type' from the summary
......................................................................
packaging: setup: removing 'Datacenter storage type' from the summary
Removing an entry from the installation summary.
Change-Id: I6042db9c4aa4653ce3329665b0a10a53a727c7df
Bug-Url: https://bugzilla.redhat.com/1102021
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/constants.py
1 file changed, 1 insertion(+), 3 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/33934
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6042db9c4aa4653ce3329665b0a10a53a727c7df
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months
Change in ovirt-engine[master]: tools: Add JVM params to notifier configuration
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: tools: Add JVM params to notifier configuration
......................................................................
tools: Add JVM params to notifier configuration
Adds ability to configure JVM properties and arguments for notifier
in configuration.
Change-Id: I0107f662660acb436871b92f25f5560ff5f4ea6f
Related-To: https://bugzilla.redhat.com/1109871
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M packaging/services/ovirt-engine-notifier/ovirt-engine-notifier.conf.in
M packaging/services/ovirt-engine-notifier/ovirt-engine-notifier.py
2 files changed, 39 insertions(+), 0 deletions(-)
Approvals:
Alon Bar-Lev: Looks good to me, but someone else must approve
Sandro Bonazzola: Looks good to me, approved
Martin Peřina: Verified
oVirt Jenkins CI Server: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/33916
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0107f662660acb436871b92f25f5560ff5f4ea6f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: packaging: setup: removing 'Datacenter storage type' from th...
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: removing 'Datacenter storage type' from the summary
......................................................................
packaging: setup: removing 'Datacenter storage type' from the summary
Removing an entry from the installation summary.
Change-Id: I6042db9c4aa4653ce3329665b0a10a53a727c7df
Bug-Url: https://bugzilla.redhat.com/1102021
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/constants.py
1 file changed, 1 insertion(+), 3 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Verified
--
To view, visit http://gerrit.ovirt.org/33932
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6042db9c4aa4653ce3329665b0a10a53a727c7df
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months
Change in ovirt-engine[master]: packaging: setup: Use common code for remote wsp pki
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: Use common code for remote wsp pki
......................................................................
packaging: setup: Use common code for remote wsp pki
Code to handle PKI stuff with remote engine has been moved
to a common place to be shared between different plugins.
Using it.
Change-Id: Id72711fb1577d5ee97454a36650456c2675206be
Bug-Url: https://bugzilla.redhat.com/1125188
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/websocket_proxy/constants.py
M packaging/setup/plugins/ovirt-engine-setup/websocket_proxy/config.py
M packaging/setup/plugins/ovirt-engine-setup/websocket_proxy/pki.py
3 files changed, 200 insertions(+), 282 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Verified
oVirt Jenkins CI Server: Looks good to me, but someone else must approve
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/33775
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id72711fb1577d5ee97454a36650456c2675206be
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: packaging: setup: using engine-common in websocketproxy plugins
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: using engine-common in websocketproxy plugins
......................................................................
packaging: setup: using engine-common in websocketproxy plugins
Loosen up engine-common requirements in order to use it
from wsp plugins.
Change-Id: I7cb1245105f913f0c82fb3b909f14584053e8a0f
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M ovirt-engine.spec.in
M packaging/setup/ovirt_engine_setup/engine_common/constants.py
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine-common/config/java.py
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/config/jboss.py
4 files changed, 14 insertions(+), 4 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/33410
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7cb1245105f913f0c82fb3b909f14584053e8a0f
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months