Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.1]: Fix the way we compute cpu_load average and add tests for it
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Fix the way we compute cpu_load average and add tests for it
......................................................................
Fix the way we compute cpu_load average and add tests for it
Change-Id: Id9e05c753f41dcd94d5a4734ac39f90581ddc0c0
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M ovirt_hosted_engine_ha/agent/Makefile.am
M ovirt_hosted_engine_ha/agent/constants.py.in
M ovirt_hosted_engine_ha/agent/state_data.py
A ovirt_hosted_engine_ha/agent/state_data_test.py
M ovirt_hosted_engine_ha/agent/state_machine.py
M ovirt_hosted_engine_ha/agent/states.py
6 files changed, 137 insertions(+), 10 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24819
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id9e05c753f41dcd94d5a4734ac39f90581ddc0c0
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.1
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.1]: Separate the state machine into machine, states with logic a...
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Separate the state machine into machine, states with logic and communication
......................................................................
Separate the state machine into machine, states with logic and communication
The FSM is designed in such a way that each state is essentially
immutable and knows only about the world that was seen when the
state was created.
When consume is called it uses the remembered info and the new info
to determine where to go next and returns a new state instance.
This allows us to write unit tests for each state without having
to mock anything as all decisions are based only on passed immutable
structures.
This patch also kills some of the timers we used and replaces them
with separate states and universal check_timer decorator.
Change-Id: Icad82e819b653cd8b9210d0a71e0312fc6b20134
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M configure.ac
M ovirt_hosted_engine_ha/agent/Makefile.am
M ovirt_hosted_engine_ha/agent/agent.py
M ovirt_hosted_engine_ha/agent/hosted_engine.py
A ovirt_hosted_engine_ha/agent/state_data.py
A ovirt_hosted_engine_ha/agent/state_decorators.py
A ovirt_hosted_engine_ha/agent/state_machine.py
A ovirt_hosted_engine_ha/agent/states.py
M ovirt_hosted_engine_ha/lib/Makefile.am
A ovirt_hosted_engine_ha/lib/fsm/Makefile.am
A ovirt_hosted_engine_ha/lib/fsm/__init__.py
A ovirt_hosted_engine_ha/lib/fsm/machine.py
M ovirt_hosted_engine_ha/lib/metadata.py
M ovirt_hosted_engine_ha/lib/util.py
14 files changed, 1,565 insertions(+), 842 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24818
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icad82e819b653cd8b9210d0a71e0312fc6b20134
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.1
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-reports[master]: packaging: setup: improve method to detect jrs version
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: improve method to detect jrs version
......................................................................
packaging: setup: improve method to detect jrs version
Change-Id: I2d42aac84660a6ea1ac8919a551edaee5255db7d
Signed-off-by: Yaniv Dary <ydary(a)redhat.com>
---
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine-reports/jasper/deploy.py
1 file changed, 8 insertions(+), 4 deletions(-)
Approvals:
Alon Bar-Lev: Looks good to me, but someone else must approve
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24793
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2d42aac84660a6ea1ac8919a551edaee5255db7d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 10 months
Change in ovirt-reports[master]: reports: added comments to br19 report queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: added comments to br19 report queries
......................................................................
reports: added comments to br19 report queries
Added comments to br19 report queries and
changed the code structure so it will be more readable.
Change-Id: Id229db4db08bc5d2f0b402f6d707dd4fda7360a0
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/Executive/cluster_capacity_vs_usage_br19_files/cluster_capacity_vs_usage_br19_jrxml.data
M packaging/ovirt-reports/resources/Reports/Executive/cluster_capacity_vs_usage_br19_files/full details br19.jrxml.data
2 files changed, 636 insertions(+), 466 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24786
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id229db4db08bc5d2f0b402f6d707dd4fda7360a0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 10 months
Change in ovirt-engine[master]: core: Use parameter instead fetching again from DB.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Use parameter instead fetching again from DB.
......................................................................
core: Use parameter instead fetching again from DB.
Use vmDynamic parameter which already fetched from the DB, instead
fetching the VM dynamic again from the DB.
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
Change-Id: I38eae06b8710136371c91f0d3b7739f58fc2792d
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Maor Lipchuk: Verified
Liron Ar: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24616
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I38eae06b8710136371c91f0d3b7739f58fc2792d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: core: decrease pending memory & cpu from the right vds on ru...
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: decrease pending memory & cpu from the right vds on run vm
......................................................................
core: decrease pending memory & cpu from the right vds on run vm
On rerun attempt in RunVm/RunVmOnce flow we could decrease the pending
resources from the wrong VDS, i.e not from the VDS the VM was supposed
to run on, in case dedicated VDS was defined for the VM or a specific
VDS was set in RunVmOnce flow.
This patch changes the selection of the VDS for which we should decrease
the pending resources to use RunVmCommandBase#getCurrentVdsId method
which should always return the VDS on which the VM was about to run on.
Change-Id: I7b82e4ef4f9e5ed60542e756640861f7403be090
Bug-Url: https://bugzilla.redhat.com/1061811
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommandBase.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/24254
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7b82e4ef4f9e5ed60542e756640861f7403be090
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: core: minor cleanups
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: minor cleanups
......................................................................
core: minor cleanups
* Remove _destinationVds from RunVmCommandBase and put relevant fields
in RunVmCommand & MigrateVmCommand. It is better in terms of
encapsulation since they are now private
* Refactor RunVmCommand#getDestinationVds to be more readable
* Remove MigrateVmCommand#forcedMigrationForNonMigratableVM
* Remove explicit usages of DbFacade class within MigrateVmCommand
* Few renames
Change-Id: I2fa22569d9195f69cec7fa9c0a4931b2975e41ec
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmToServerCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommandBase.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/MigrateVmParameters.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendVmResourceTest.java
6 files changed, 60 insertions(+), 51 deletions(-)
Approvals:
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24160
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2fa22569d9195f69cec7fa9c0a4931b2975e41ec
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: webadmin: new pool dialog should not contain Blank template
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: webadmin: new pool dialog should not contain Blank template
......................................................................
webadmin: new pool dialog should not contain Blank template
This regression has been introduced by:
604d22dc036d1f5a4431c8247ce246d0c0a0c109
Fixed by moving back the code to filter out the Blank template from the new
pool dialog.
Change-Id: I6acdd3427e5c11b854bfd4c9c209c55da12b88a5
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1066646
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/NewPoolModelBehavior.java
1 file changed, 11 insertions(+), 3 deletions(-)
Approvals:
Tomas Jelinek: Verified
Gustavo Frederico Temple Pedrosa: Looks good to me, but someone else must approve
Gilad Chaplik: Looks good to me, approved
Arik Hadas: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/24738
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6acdd3427e5c11b854bfd4c9c209c55da12b88a5
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Gustavo Frederico Temple Pedrosa <gustavo.pedrosa(a)eldorado.org.br>
Gerrit-Reviewer: Leonardo Bianconi <leonardo.bianconi(a)eldorado.org.br>
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vitor de Lima <vitor.lima(a)eldorado.org.br>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: webadmin: search paging on event log does not use paging cor...
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: webadmin: search paging on event log does not use paging correctly
......................................................................
webadmin: search paging on event log does not use paging correctly
search paging on event log does not use paging
correctly If we browse to 2nd page from UI Events
TAB by pressing the '>' button and then put
"Vms: page 1" as the search text , we an error
on server side
Change-Id: I86787302601365e07f9d923f26d483c7bceb30ef
Bug-Url: https://bugzilla.redhat.com/1064395
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/SearchableListModel.java
1 file changed, 10 insertions(+), 0 deletions(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
Ravi Nori: Verified
--
To view, visit http://gerrit.ovirt.org/24732
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I86787302601365e07f9d923f26d483c7bceb30ef
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[ovirt-engine-3.4]: core: GetActiveVmsByStorageDomainId - consider disk snapshots
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: core: GetActiveVmsByStorageDomainId - consider disk snapshots
......................................................................
core: GetActiveVmsByStorageDomainId - consider disk snapshots
GetActiveVmsByStorageDomainId should also returns vms that has plugged
disk snapshots on the domain.
Change-Id: I910d61ae2cf33782eac2ca53d92deb03a29f8531
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M packaging/dbscripts/vms_sp.sql
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Liron Ar: Verified
--
To view, visit http://gerrit.ovirt.org/24743
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I910d61ae2cf33782eac2ca53d92deb03a29f8531
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months