Change in ovirt-engine[ovirt-engine-3.4]: tools: notifier: fix NotificationPropertiesTest.
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: tools: notifier: fix NotificationPropertiesTest.
......................................................................
tools: notifier: fix NotificationPropertiesTest.
Call NotificationProperties.release() so we do not
get a stale copy of Notification Properties.
(Set default and get instance are not enough
if the current class loader has a copy of
NotificationProperties with an old instance
we will get that one!)
also enable NotificationPropertiesTest to run both under maven and straight
from source thus speeding up testing during development.
Change-Id: Ia3488856323577e3db6c779d86c190e064e15c97
Signed-off-by: Mooli Tayer <mtayer(a)redhat.com>
---
M backend/manager/tools/src/test/java/org/ovirt/engine/core/notifier/utils/NotificationPropertiesTest.java
1 file changed, 7 insertions(+), 3 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved
mooli tayer: Verified; Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/24691
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia3488856323577e3db6c779d86c190e064e15c97
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: mooli tayer <mtayer(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[ovirt-engine-3.4]: utils: LocalConfig: add getProperty with an optionalSuffix S...
by iheim@redhat.com
Itamar Heim has submitted this change and it was merged.
Change subject: utils: LocalConfig: add getProperty with an optionalSuffix String.
......................................................................
utils: LocalConfig: add getProperty with an optionalSuffix String.
public String getProperty(String key, String optionalSuffix, boolean allowMissing);
Returns the value associated with key_optionalSuffix if it is defined or the one
associated with key. If both are missing and allowMissing = false throws an
IllegalStateException.
Change-Id: Ic37b6aa5ce44600fc647915b9f71632c98bbbae3
Signed-off-by: Mooli Tayer <mtayer(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/LocalConfig.java
M backend/manager/modules/utils/src/test/java/org/ovirt/engine/core/utils/LocalConfigTest.java
M backend/manager/modules/utils/src/test/resources/localconfig.conf
M backend/manager/modules/utils/src/test/resources/localconfig.conf.ref
4 files changed, 53 insertions(+), 6 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved
mooli tayer: Verified; Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/24690
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic37b6aa5ce44600fc647915b9f71632c98bbbae3
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: mooli tayer <mtayer(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: core: change asyncRunningVms to be Set
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: change asyncRunningVms to be Set
......................................................................
core: change asyncRunningVms to be Set
ResourceManager#_asyncRunningVms used to be of type ConcurrentHashMap
but provided functionality of Set. Since Java 1.6 there is an easy
way to create thread-safe Set which is based on ConcurrentHashMap. By
setting the asyncRunningVms collection to such Set, our code becomes
more expressive and easier to read, and we don't change the correctness
since we are using the same underlying implementation (one difference
though is that the implementation now uses put instead of putIfAbsent,
but it does not matter because we are always using the same value).
This patch also contains minor refactoring in ResourceManager.
Change-Id: I807936d76ee7298a126e7dd61d75cbb345e06829
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/ResourceManager.java
1 file changed, 24 insertions(+), 27 deletions(-)
Approvals:
Roy Golan: Looks good to me, approved
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24552
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I807936d76ee7298a126e7dd61d75cbb345e06829
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: core: remove RunVmCommandBase#getDestinationVds
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: remove RunVmCommandBase#getDestinationVds
......................................................................
core: remove RunVmCommandBase#getDestinationVds
In light of 84fc3c7 RunVmCommandBase#getDestinationVds is now used
only by classes which extend RunVmCommandBase and is used differently:
MigrateVm returns the VDS that the VM is going to migrate to, RunVm &
RunVmOnce return the predefined VDS on which the VM should run on.
This patch removes RunVmCommandBase#getDestinationVds method. In RunVm
it is replaced by getPredefinedDestinationVdsId method which reflect the
result better by its name and returns only the ID of the VDS.
In addition, minor improvement was made in
MigrateVmCommand#getDestinationVds, and calls to it where we only need
the ID of the VDS were replaced by calls to
MigrateVmCommand#getDestinationVdsId.
Change-Id: Ie1d8fb852a88203378b3bcd3f1d6f96e469e5cb9
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmOnceCommand.java
4 files changed, 31 insertions(+), 56 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24255
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie1d8fb852a88203378b3bcd3f1d6f96e469e5cb9
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-engine[master]: webadmin: fixed layout of total VCPUs editor
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: webadmin: fixed layout of total VCPUs editor
......................................................................
webadmin: fixed layout of total VCPUs editor
The broken layout was caused by using custom styling
of the widget with info icon.
Fixed by using the standard EntityModelWidgetWithInfo widget.
Change-Id: Iadb78a9bba4c98d5189463a19471e248c2e3f902
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.ui.xml
2 files changed, 20 insertions(+), 21 deletions(-)
Approvals:
Tomas Jelinek: Verified
Gilad Chaplik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24827
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iadb78a9bba4c98d5189463a19471e248c2e3f902
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months
Change in ovirt-reports[master]: reports: edited input controls queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: edited input controls queries
......................................................................
reports: edited input controls queries
In this patch I edited the input controls queris,
so they will be more readable and added comments.
Change-Id: I56bd7583fd20c1ead3c760a922a37b5c1ac87da5
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/non-002dquery_IC/P_Period.xml
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/non-002dquery_IC/P_Start_Date.xml
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/non-002dquery_IC/is_deleted.xml
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/single_select/cluster_ic/all_cluster_with_vms/P_Cluster_ID.xml
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/single_select/datacenter_ic/all_dcs_with_vms/P_DataCenter_ID.xml
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Period_Affected/single_select/vm_ic/P_VM_Type.xml
6 files changed, 723 insertions(+), 243 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24676
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I56bd7583fd20c1ead3c760a922a37b5c1ac87da5
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 10 months
Change in ovirt-reports[master]: Revert "packaging: setup: now deploys with correct app name ...
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: Revert "packaging: setup: now deploys with correct app name with jrs pro"
......................................................................
Revert "packaging: setup: now deploys with correct app name with jrs pro"
This reverts commit 813cec66e69a5a2db3430973508b2e6e0902bdba.
Change-Id: I99b88114416de1ce6022a546e3c15f6a5d9d485c
Signed-off-by: Yaniv Dary <ydary(a)redhat.com>
---
M packaging/conf/jasper-master.properties.in
M packaging/setup/ovirt_engine_setup/reportsconfig.py.in
M packaging/setup/ovirt_engine_setup/reportsconstants.py
3 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24825
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I99b88114416de1ce6022a546e3c15f6a5d9d485c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 10 months
Change in ovirt-engine[master]: packaging: setup: cleanup nfs exports usage
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: cleanup nfs exports usage
......................................................................
packaging: setup: cleanup nfs exports usage
1. if exports.d exists and we registered ourselves previously in
exports, move the entry to our own file.
2. if ACL specified enforce a new entry.
3. do not touch anything on upgrade unless (2).
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1058018
Change-Id: Ie3df61b1b52aead5ddf457da14f26324dbc2a56c
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/constants.py
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/system/exportfs.py
2 files changed, 121 insertions(+), 82 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Sandro Bonazzola: Looks good to me, approved
Ofer Schreiber: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/24470
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie3df61b1b52aead5ddf457da14f26324dbc2a56c
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Ofer Schreiber <oschreib(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
10 years, 10 months
Change in ovirt-reports[master]: packaging: setup: now deploys with correct app name with jrs...
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: now deploys with correct app name with jrs pro
......................................................................
packaging: setup: now deploys with correct app name with jrs pro
Change-Id: I3378365a7bcdcacb4fe471b4e786b7aa24badbd6
Signed-off-by: Yaniv Dary <ydary(a)redhat.com>
---
M packaging/conf/jasper-master.properties.in
M packaging/setup/ovirt_engine_setup/reportsconfig.py.in
M packaging/setup/ovirt_engine_setup/reportsconstants.py
3 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
Objections:
Alon Bar-Lev: I would prefer that you didn't submit this
--
To view, visit http://gerrit.ovirt.org/24805
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3378365a7bcdcacb4fe471b4e786b7aa24badbd6
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 10 months
Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.1]: Add make test, make it work and use it in rpm build
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Add make test, make it work and use it in rpm build
......................................................................
Add make test, make it work and use it in rpm build
Change-Id: If7162928be49d1f505abc44d8f61c1d17b18de5b
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M Makefile.am
M ovirt-hosted-engine-ha.spec.in
A ovirt_hosted_engine_ha/broker/test/__init__.py
M ovirt_hosted_engine_ha/broker/test/test_monitor.py
4 files changed, 8 insertions(+), 2 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/24820
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If7162928be49d1f505abc44d8f61c1d17b18de5b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.1
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 10 months