Change in ovirt-hosted-engine-ha[master]: packaging: cleanups
by gpadgett@redhat.com
Greg Padgett has submitted this change and it was merged.
Change subject: packaging: cleanups
......................................................................
packaging: cleanups
- Aligned Requires with 1.1 branch
- Added missing BuildRequire on vdsm-cli needed for %check
- Fixed PEP8 issues detected by python-pep8-1.5.6-3
Change-Id: I5b77dd51b58ef2986cca95f51a15c3df2870faa8
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M ovirt-hosted-engine-ha.spec.in
M ovirt_hosted_engine_ha/agent/states.py
M ovirt_hosted_engine_ha/broker/listener.py
M ovirt_hosted_engine_ha/lib/storage_backends.py
4 files changed, 26 insertions(+), 19 deletions(-)
Approvals:
Sandro Bonazzola: Verified
Greg Padgett: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28860
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5b77dd51b58ef2986cca95f51a15c3df2870faa8
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Greg Padgett <gpadgett(a)redhat.com>
Gerrit-Reviewer: Jiří Moskovčák <jmoskovc(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: engine: Remove unused code from CommandBase.
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Remove unused code from CommandBase.
......................................................................
engine: Remove unused code from CommandBase.
Private methods getAsyncTask and internalGetTaskType aren't in use.
Thus were removed.
Change-Id: I5c85e76d53a1bcaa830815c212102bd8d198cd9e
Signed-off-by: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
1 file changed, 0 insertions(+), 18 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28630
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c85e76d53a1bcaa830815c212102bd8d198cd9e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in mom[master]: Update mom version to 0.4.1
by alitke@redhat.com
Adam Litke has submitted this change and it was merged.
Change subject: Update mom version to 0.4.1
......................................................................
Update mom version to 0.4.1
Change-Id: I7a7cfd4ba39c0a9e1956ff867ca2de8957b15135
Signed-off-by: Adam Litke <alitke(a)redhat.com>
Reviewed-on: http://gerrit.ovirt.org/28914
---
M configure.ac
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Adam Litke: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28914
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7a7cfd4ba39c0a9e1956ff867ca2de8957b15135
Gerrit-PatchSet: 2
Gerrit-Project: mom
Gerrit-Branch: master
Gerrit-Owner: Adam Litke <alitke(a)redhat.com>
Gerrit-Reviewer: Adam Litke <alitke(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in mom[master]: Adding support in CPU monitoring
by alitke@redhat.com
Adam Litke has submitted this change and it was merged.
Change subject: Adding support in CPU monitoring
......................................................................
Adding support in CPU monitoring
Adding two new collectors and a controller to enable
monitoring the CPU tuning parameters: vcpu_quota, vcpu_period.
This patch is part of the CPU SLA feature: http://www.ovirt.org/Features/CPU_SLA.
Changes in collectors:
Added a new utility method to Collector.py, "count_int",
count the number of matches in a string according to a regular expression.
Added HostCpu to expose the number of cpu on the host.
Added GuestCpuTune to expose the current tuning parameters and the latest user selection
Changes in controller:
Added CpuTune to apply changes to the vcpu tuning.
This patch is used in the cputune.policy, some code snip:
(defvar anchor 100000)
(def check_and_set_quota (guest)
{
(defvar calcQuota (/ (* anchor (/ guest.user_vcpu_limit 100))) guest.vcpu_count)
(if (!= guest.vcpu_quota calcQuota)
(guest.Control "vcpu_quota" calcQuota) 0)
})
Change-Id: I66aa9723d3cfc6fc1c1d36a3bf42086abd010f26
Reviewed-on: http://gerrit.ovirt.org/27240
Tested-by: Kobi Ianko <kobi(a)redhat.com>
Reviewed-by: Adam Litke <alitke(a)redhat.com>
Signed-off-by: Kobi Ianko <kianku(a)redhat.com>
Reviewed-on: http://gerrit.ovirt.org/28815
Tested-by: Adam Litke <alitke(a)redhat.com>
---
M mom/Collectors/Collector.py
A mom/Collectors/GuestCpuTune.py
A mom/Collectors/HostCpu.py
M mom/Collectors/Makefile.am
A mom/Controllers/CpuTune.py
M mom/Controllers/Makefile.am
M mom/HypervisorInterfaces/libvirtInterface.py
M mom/HypervisorInterfaces/vdsmInterface.py
8 files changed, 248 insertions(+), 0 deletions(-)
Approvals:
Adam Litke: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28815
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I66aa9723d3cfc6fc1c1d36a3bf42086abd010f26
Gerrit-PatchSet: 5
Gerrit-Project: mom
Gerrit-Branch: master
Gerrit-Owner: Kobi Ianko <kobi(a)redhat.com>
Gerrit-Reviewer: Adam Litke <alitke(a)redhat.com>
Gerrit-Reviewer: Kobi Ianko <kobi(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-engine[master]: core: NPE on UpdateVmVersion call to GetVmPayloadQuery
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: NPE on UpdateVmVersion call to GetVmPayloadQuery
......................................................................
core: NPE on UpdateVmVersion call to GetVmPayloadQuery
some changes in the session mgmt caused a NPE on the call to
GetVmPayloadQuery from UpdateVmVersionCommand.
The NPE caused because the session isn't automatically copied to the
query, so in this patch it is manually set in the query params.
Change-Id: If0a0a5cf79a6eb7967ed4ae4454a763773b23d65
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmVersionCommand.java
1 file changed, 3 insertions(+), 2 deletions(-)
Approvals:
Omer Frenkel: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28862
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If0a0a5cf79a6eb7967ed4ae4454a763773b23d65
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: core: fix deadlock on update vm version
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: fix deadlock on update vm version
......................................................................
core: fix deadlock on update vm version
When a new template version created,
all vms using 'latest' of the template are updated to the new version.
seems that the update of template child count inside the insertVmStatic
stored procedure caused deadlock in db, because it would do select
count(*) on the table, without taking any lock.
in this patch the insert/delete vm static stored procedures are changed
to take a lock on the template, and the update line changed to +1 / -1
instead of count(*), because of the lock, now it is safe to do.
Change-Id: I2dfdb556e66658c3ef630cf71fba5f902ea26862
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmTemplateCommand.java
M packaging/dbscripts/vms_sp.sql
2 files changed, 11 insertions(+), 11 deletions(-)
Approvals:
Eli Mesika: Looks good to me, but someone else must approve
Shahar Havivi: Looks good to me, approved
Omer Frenkel: Verified
Arik Hadas: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/28861
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2dfdb556e66658c3ef630cf71fba5f902ea26862
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <elimesika(a)gmail.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: core: refactor CommonVmPoolWithVmsCommand
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: refactor CommonVmPoolWithVmsCommand
......................................................................
core: refactor CommonVmPoolWithVmsCommand
- Extract the code that add VMs to the pool to separate method
- Rename addVmsSucceded to addVmsSucceeded
- Remove the variable that reflected whether at least one VM creation
failed as we can know that according to the addVmsSucceeded field
- Rename getAddVmsSucceeded to isAddVmsSucceeded
Change-Id: If9cc7214071e0b92aaa65480f0c5c801538d2c50
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmPoolWithVmsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommonVmPoolWithVmsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmPoolWithVmsCommand.java
3 files changed, 16 insertions(+), 14 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/28325
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If9cc7214071e0b92aaa65480f0c5c801538d2c50
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: restapi: add scheduling policy elements to rsdl_metadata.yaml
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: add scheduling policy elements to rsdl_metadata.yaml
......................................................................
restapi: add scheduling policy elements to rsdl_metadata.yaml
Complementing http://gerrit.ovirt.org/#/c/28093/ .
Marking cluster's fields: scheduling_policy.id and
scheduling_policy.thresholds (low, high and duration) as deprecated.
Change-Id: I36f5efe9f82c914e0dec80572b2500e6839e5f7b
Signed-off-by: Gilad Chaplik <gchaplik(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
1 file changed, 263 insertions(+), 9 deletions(-)
Approvals:
Ori Liel: Looks good to me, approved
Gilad Chaplik: Verified
--
To view, visit http://gerrit.ovirt.org/28877
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I36f5efe9f82c914e0dec80572b2500e6839e5f7b
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 7 months
Change in ovirt-engine[master]: webadmin: reposition active domain in DC checkbox
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: reposition active domain in DC checkbox
......................................................................
webadmin: reposition active domain in DC checkbox
Moved 'active domain in DC' checkbox near DCs listbox.
Screenshot: http://i.imgur.com/hxyTvEg.jpg
Change-Id: I6bdd7a469922c8ec9ffaa51518b1d65796945b3f
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/storage/StoragePopupView.ui.xml
1 file changed, 3 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Daniel Erez: Verified
--
To view, visit http://gerrit.ovirt.org/28850
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6bdd7a469922c8ec9ffaa51518b1d65796945b3f
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months
Change in ovirt-engine[master]: webadmin: import domain - hide activate on none DC
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: import domain - hide activate on none DC
......................................................................
webadmin: import domain - hide activate on none DC
Import storage domain dialog:
hide activate checkbox when selecting 'none' DC.
Change-Id: I2d26cf3487e28dcb3319784d0f74cf589f072ec8
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/ImportStorageModelBehavior.java
1 file changed, 9 insertions(+), 1 deletion(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28855
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2d26cf3487e28dcb3319784d0f74cf589f072ec8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 7 months