Change in ovirt-engine[master]: core: short cycle for unmanaged VMs
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: short cycle for unmanaged VMs
......................................................................
core: short cycle for unmanaged VMs
Change-Id: I341d8d5f535c900e2e1bfad96430f45c77eeb551
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmAnalyzer.java
1 file changed, 9 insertions(+), 14 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Looks good to me, but someone else must approve
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/51939
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I341d8d5f535c900e2e1bfad96430f45c77eeb551
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: automation: add quick validation
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: automation: add quick validation
......................................................................
automation: add quick validation
Change-Id: Ic73bcaf8388bfa9b505b5ec623a7a6188ce9e8ca
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M automation/check-patch.sh
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
David Caro: Looks good to me, but someone else must approve
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/52519
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic73bcaf8388bfa9b505b5ec623a7a6188ce9e8ca
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaro(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: new hook error code
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: core: new hook error code
......................................................................
core: new hook error code
Change-Id: I0f34736629eaeaabf207e99d178de4bf1456ea4e
Signed-off-by: pkliczewski <piotr.kliczewski(a)gmail.com>
Bug-Url: https://bugzilla.redhat.com/1295778
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineError.java
M backend/manager/modules/dal/src/main/resources/bundles/VdsmErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/VdsmErrors.java
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/VdsmErrors.properties
4 files changed, 8 insertions(+), 0 deletions(-)
Approvals:
Piotr Kliczewski: Verified
Jenkins CI: Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/51631
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0f34736629eaeaabf207e99d178de4bf1456ea4e
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: restapi: Initial support for multiple versions
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Initial support for multiple versions
......................................................................
restapi: Initial support for multiple versions
This patch adds initial support for having multiple versions of the API
in the same server. It covers only the metadata part, that is, the XML
schema and the RSDL.
The versions supported will be "3" and "4".
The metadata for version "3" is just a copy of the metadata files used
in the 3.x branch of the engine. This will need to be updated from time
to time to keep it in sync with the 3.6 branch, till that branch is
definitively closed.
The metadata for version "4" is automatically generated from the model.
The patch also adds initial support for the "Version" header, so that
the user can indicate what version of the API to use, right now only for
the metadata. For example, to request version 3 of the XML schema the
user can send a request like this:
GET /ovirt-engine/api?schema
Version: 3
Same for the RSDL:
GET /ovirt-engine/api?rsdl
Version: 3
When the "Version" header isn't provided the default will be used,
whichis currently version 4.
Change-Id: I13adfd3feb0a3d56133facb399a93c2e7e0d9ac3
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/pom.xml
M backend/manager/modules/restapi/interface/definition/src/main/java/org/ovirt/engine/api/rsdl/RsdlIOManager.java
M backend/manager/modules/restapi/interface/definition/src/main/java/org/ovirt/engine/api/rsdl/RsdlManager.java
A backend/manager/modules/restapi/interface/definition/src/main/resources/v3/api.xsd
A backend/manager/modules/restapi/interface/definition/src/main/resources/v3/rsdl.xml
A backend/manager/modules/restapi/interface/definition/src/main/resources/v3/rsdl_gluster.xml
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/invocation/Current.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/invocation/CurrentFilter.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendApiResource.java
M pom.xml
10 files changed, 36,685 insertions(+), 59 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51559
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I13adfd3feb0a3d56133facb399a93c2e7e0d9ac3
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: webadmin: Added fontend null checks
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Added fontend null checks
......................................................................
webadmin: Added fontend null checks
* Null check added into TagModelProvider.initializeModelHandlers()
to prevent NPE.
* Null check added into
VmSnapshotListModel.updateIsCloneVmSupported() to prevent NPE.
Change-Id: I1b5688555ca2cdb95f4dc91ba5494d90709fa4b8
Bug-Url: https://bugzilla.redhat.com/1293269
Signed-off-by: Jakub Niedermertl <jniederm(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/uicommon/model/TagModelProvider.java
2 files changed, 6 insertions(+), 0 deletions(-)
Approvals:
Jakub Niedermertl: Verified
Jenkins CI: Passed CI tests
Vojtech Szocs: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/52385
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1b5688555ca2cdb95f4dc91ba5494d90709fa4b8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Add test to PowerManagementUtilsTest
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Add test to PowerManagementUtilsTest
......................................................................
core: Add test to PowerManagementUtilsTest
Change-Id: I82cfdc0b98ae4e5c71a6177770858c96ca3a05c4
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/pm/PowerManagementUtilsTest.java
1 file changed, 9 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52364
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I82cfdc0b98ae4e5c71a6177770858c96ca3a05c4
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Remove duplicate code
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove duplicate code
......................................................................
core: Remove duplicate code
FenceAgent and VdsStatic contained the exact same pmOptionsStringToMap
method, this patch extracts it to a helper class and removed the dupicate
refernces
Change-Id: Ib2f948d674f1501a0ab7247373bf21cc3770b87e
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VdsStatic.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/pm/FenceAgent.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/pm/PowerManagementUtils.java
R backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/pm/PowerManagementUtilsTest.java
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostModel.java
6 files changed, 45 insertions(+), 70 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52363
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib2f948d674f1501a0ab7247373bf21cc3770b87e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: engine-setup: check for deprecated notifier events
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: engine-setup: check for deprecated notifier events
......................................................................
engine-setup: check for deprecated notifier events
This patch checks in engine-notifier custom configuration files if any
event including "VDS_GROUP" is used in FILTER settings.
If found, the user is asked to change that and restart the setup or
continue and change that after setup is completed
Change-Id: Id6046c82dbf9dbbbb62d958cd6435d21428da7b0
Signed-off-by: emesika <emesika(a)redhat.com>
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/engine/constants.py
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/config/__init__.py
A packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/config/notifier.py
3 files changed, 104 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Eli Mesika: Verified; Looks good to me, approved; Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
Oved Ourfali: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/51843
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id6046c82dbf9dbbbb62d958cd6435d21428da7b0
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine-sdk[refs/meta/config]: Remove the "workflow" label
by dcaro@redhat.com
David Caro has submitted this change and it was merged.
Change subject: Remove the "workflow" label
......................................................................
Remove the "workflow" label
This work doesn't have any use in the development process of the SDK.
Change-Id: I325035596a7edc509d6c70eed0afefbbb9948718
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M groups
M project.config
2 files changed, 0 insertions(+), 17 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, but someone else must approve; Passed CI tests
David Caro: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/52506
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I325035596a7edc509d6c70eed0afefbbb9948718
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: refs/meta/config
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaro(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.3]: upgrade: adding a docstring for _is_conf_volume_there
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: upgrade: adding a docstring for _is_conf_volume_there
......................................................................
upgrade: adding a docstring for _is_conf_volume_there
The code to detect the configuration image is not trivial so
it's better to describe it.
Since nothing calls prepareImage on the configuration image before
we discover it, the volume shouldn't be available but it is so
it's better to keep track of this behavior.
Change-Id: I09cac64724fe77e51687ecaf558dc1eec47a5daa
Bug-Url: https://bugzilla.redhat.com/1297457
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M ovirt_hosted_engine_ha/lib/upgrade.py
1 file changed, 10 insertions(+), 0 deletions(-)
Approvals:
Martin Sivák: Looks good to me, approved
Simone Tiraboschi: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52502
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I09cac64724fe77e51687ecaf558dc1eec47a5daa
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.3
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months