Change in ovirt-engine-sdk-ruby[master]: Improve error handling
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: Improve error handling
......................................................................
Improve error handling
This patch improves the error handling of the SDK, so that services will
check the results received from the server and transform them into the
corresponding exceptions.
Change-Id: I55903e5278d3405c214e5c2380df9d389f780391
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M generator/src/main/java/org/ovirt/sdk/ruby/ReadersGenerator.java
M generator/src/main/java/org/ovirt/sdk/ruby/RubyNames.java
M generator/src/main/java/org/ovirt/sdk/ruby/ServicesGenerator.java
M generator/src/main/java/org/ovirt/sdk/ruby/TypesGenerator.java
M sdk/examples/add_cluster.rb
M sdk/examples/add_data_center.rb
M sdk/examples/add_host.rb
M sdk/examples/add_nfs_data_storage_domain.rb
M sdk/examples/add_nfs_iso_storage_domain.rb
M sdk/examples/add_vm.rb
M sdk/examples/add_vm_disk.rb
M sdk/examples/add_vm_nic.rb
M sdk/examples/attach_nfs_data_storage_domain.rb
M sdk/examples/attach_nfs_iso_storage_domain.rb
M sdk/examples/list_vms.rb
A sdk/examples/remove_host.rb
M sdk/examples/remove_vm.rb
M sdk/examples/search_vms.rb
M sdk/examples/start_vm.rb
M sdk/examples/stop_vm.rb
A sdk/examples/update_data_center.rb
A sdk/lib/ovirt/sdk/v4/readers/action_reader.rb
M sdk/lib/ovirt/sdk/v4/services/service.rb
A sdk/lib/ovirt/sdk/v4/types/action.rb
A sdk/spec/action_reader_spec.rb
A sdk/spec/service_spec.rb
26 files changed, 683 insertions(+), 170 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52459
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I55903e5278d3405c214e5c2380df9d389f780391
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine-sdk-ruby[master]: Add fault class and reader
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: Add fault class and reader
......................................................................
Add fault class and reader
This patch adds a classes to represent and read "fault" objects returned
by the server.
Change-Id: Id2c96b9550aacad7709d118840362a0516c4745d
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M generator/src/main/java/org/ovirt/sdk/ruby/ReadersGenerator.java
M generator/src/main/java/org/ovirt/sdk/ruby/RubyNames.java
M generator/src/main/java/org/ovirt/sdk/ruby/TypesGenerator.java
A sdk/lib/ovirt/sdk/v4/readers/fault_reader.rb
A sdk/lib/ovirt/sdk/v4/types/fault.rb
A sdk/spec/fault_reader_spec.rb
6 files changed, 193 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52458
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id2c96b9550aacad7709d118840362a0516c4745d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine-sdk-ruby[master]: Add request and response classes
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: Add request and response classes
......................................................................
Add request and response classes
This patch adds two new "Request" and "Response" classes. These classes
are intended to carry the details of HTTP requests and responses. With
them the "Connection.send" method can return a response, containing the
HTTP response code, message and body, so that other parts of the SDK
will in the future be able to inspect them and act accordingly.
Change-Id: I1801639bea2e419f956133e070b7f22dee24985d
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M generator/src/main/java/org/ovirt/sdk/ruby/ServicesGenerator.java
M sdk/lib/ovirt/sdk/v4.rb
M sdk/lib/ovirt/sdk/v4/connection.rb
M sdk/spec/connection_spec.rb
4 files changed, 148 insertions(+), 109 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52409
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1801639bea2e419f956133e070b7f22dee24985d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine-sdk-ruby[master]: Add support for following links
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: Add support for following links
......................................................................
Add support for following links
This patch adds a new "follow_link" method that can be used to retrieve the
complete representation of objects that have the "href" attribute.
# Find the cluster:
cluster = ...
# Get the data center, which will probably be just a link, not
# the complete information:
dc = cluster.dc
# If the data center is a link, then follow it, to get the
# complete representation:
if dc.is_link?
dc = dc.follow_link
end
Change-Id: I02a033ea09a37995c3dcf711216d29d141436ba7
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M sdk/lib/ovirt/sdk/v4/types/list.rb
M sdk/lib/ovirt/sdk/v4/types/struct.rb
2 files changed, 57 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51909
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I02a033ea09a37995c3dcf711216d29d141436ba7
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine-sdk-ruby
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: dal: Fix stored procedure names
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: dal: Fix stored procedure names
......................................................................
dal: Fix stored procedure names
Inconsistent usage of plural in SP names expected by java code vs. actual names
defined in the DB caused SQLExceptions when creating VM in UserPortal.
Fixed by renaming DB names to form expected by backend.
Change-Id: I4c0e05da2a43dd06584f0ec042a7ac9296682e38
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M packaging/dbscripts/storages_sp.sql
M packaging/dbscripts/vds_groups_sp.sql
2 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved; Passed CI tests
Martin Betak: Verified
--
To view, visit https://gerrit.ovirt.org/52452
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4c0e05da2a43dd06584f0ec042a7ac9296682e38
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-live[ovirt-live-3.6]: build: ovirt-live-3.6.2_rc3
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: build: ovirt-live-3.6.2_rc3
......................................................................
build: ovirt-live-3.6.2_rc3
Change-Id: Icc65840d091d0772a4d14b76b184374bbfb6c576
Signed-off-by: Lev Veyde <lveyde(a)redhat.com>
---
M centos-7/Makefile
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52477
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icc65840d091d0772a4d14b76b184374bbfb6c576
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-live
Gerrit-Branch: ovirt-live-3.6
Gerrit-Owner: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: ValidateSessionQueryTest asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ValidateSessionQueryTest asserts
......................................................................
core: ValidateSessionQueryTest asserts
Replaced the unintuitive assertTrue calls with intuitive assertEquals
calls that give a better output in case the test should fail.
Change-Id: I14ae9891c1723df284b0fad910eea5743068b68f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/aaa/ValidateSessionQueryTest.java
1 file changed, 3 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52326
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I14ae9891c1723df284b0fad910eea5743068b68f
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GetHostListFromExternalProviderQuery streaming API
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetHostListFromExternalProviderQuery streaming API
......................................................................
core: GetHostListFromExternalProviderQuery streaming API
Used Java 8 streaming API when creating new collections instead of
cumbersome for-loops.
Change-Id: I6f4457b3e2418ada7cff5c3545759a9b77dda73d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetHostListFromExternalProviderQuery.java
1 file changed, 2 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/52271
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6f4457b3e2418ada7cff5c3545759a9b77dda73d
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: FenceValidator#isStartupTimeoutPassed logic
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: FenceValidator#isStartupTimeoutPassed logic
......................................................................
core: FenceValidator#isStartupTimeoutPassed logic
Simplified boolean logic to make the method easier to read.
Change-Id: I9bfbd7c2b2198dc32fd6a535e9b7230b688e257a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/FenceValidator.java
1 file changed, 1 insertion(+), 5 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/52257
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9bfbd7c2b2198dc32fd6a535e9b7230b688e257a
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: dao tests should fail fast with clear error message
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: core: dao tests should fail fast with clear error message
......................................................................
core: dao tests should fail fast with clear error message
We need to stop tests asap if initialization failed. Doing so, we
get rid of big number of 'false failures' hiding true failure,
humongous log file, and save some cpu time (on
my pc tests fails for bad initialization in 1m36.919s instead of
former 3m41.748s).
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
Change-Id: I86783a6849577c3a24692a099d6d0440a706fb54
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/BaseDaoTestCase.java
1 file changed, 37 insertions(+), 8 deletions(-)
Approvals:
Martin Mucha: Verified
Moti Asayag: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/50757
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I86783a6849577c3a24692a099d6d0440a706fb54
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months