Change in ovirt-engine[master]: core: TryBackToAllSnapshotsOfVmCommandTest mocking
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TryBackToAllSnapshotsOfVmCommandTest mocking
......................................................................
core: TryBackToAllSnapshotsOfVmCommandTest mocking
Remove the mocking in testValidateWithEmptySnapshotGuid that's just
duplicated from the setUp method.
Change-Id: I7a4ff850146116a73dc373c08bb36b5b31707aef
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/TryBackToAllSnapshotsOfVmCommandTest.java
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
Ala Hino: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/64703
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7a4ff850146116a73dc373c08bb36b5b31707aef
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: TryBackToAllSnapshotsOfVmCommandTest @Spy annotation
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TryBackToAllSnapshotsOfVmCommandTest @Spy annotation
......................................................................
core: TryBackToAllSnapshotsOfVmCommandTest @Spy annotation
Spy the command with the @Spy annotation instead of explicitly calling
Mockito.spy. This change has two advantages - first, it's a tad more
elegant, as it saves the duplicate Mockito.spy calls. Second, and more
importantly, it sets the ground for using injected mocks in these tests
in the future.
Note: A public setDstSnapshotId was added to
TryBackToAllSnapshotsOfVmParameters in order to facilitate this
change.
Change-Id: I16a39f9fb3cb09cad18a926eda8c817c24005cca
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/TryBackToAllSnapshotsOfVmCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/TryBackToAllSnapshotsOfVmParameters.java
2 files changed, 17 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
Ala Hino: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/64702
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I16a39f9fb3cb09cad18a926eda8c817c24005cca
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: TryBackToAllSnapshotsOfVmCommandTest InjectorRule
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TryBackToAllSnapshotsOfVmCommandTest InjectorRule
......................................................................
core: TryBackToAllSnapshotsOfVmCommandTest InjectorRule
Remove the InjectorRule that does nothing but shadow the one in the
base class.
Change-Id: Ieb107e115cef2f519d1e5d0887520bfc186b0946
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/TryBackToAllSnapshotsOfVmCommandTest.java
1 file changed, 0 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
Ala Hino: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/64701
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ieb107e115cef2f519d1e5d0887520bfc186b0946
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: ImportVMFromConfigurationCommandTest stubbing
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVMFromConfigurationCommandTest stubbing
......................................................................
core: ImportVMFromConfigurationCommandTest stubbing
Replaced the command's stubbing with standard mocking. It seems as
though this was originally done when logic was used in the
constructor, but since it was moved out to the init() method, it's no
longer needed.
Change-Id: Iff90201a6ae0df955756a998f1f35d36fe06dd6d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/exportimport/ImportVMFromConfigurationCommandTest.java
1 file changed, 3 insertions(+), 20 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/64670
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff90201a6ae0df955756a998f1f35d36fe06dd6d
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: TryBackToAllSnapshotsofVmCommandTest local var
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TryBackToAllSnapshotsofVmCommandTest local var
......................................................................
core: TryBackToAllSnapshotsofVmCommandTest local var
Convert the snapshot member to a local variable to make the code
cleaner and more concise.
Change-Id: Ife6a86294825d44e9d2dbb89317b5daa1a9b66da
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/TryBackToAllSnapshotsOfVmCommandTest.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
Ala Hino: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/64700
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ife6a86294825d44e9d2dbb89317b5daa1a9b66da
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: VmsSlaPolicyCommandTest @Spy annotation
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: VmsSlaPolicyCommandTest @Spy annotation
......................................................................
core: VmsSlaPolicyCommandTest @Spy annotation
Spy the command with the @Spy annotation instead of explicitly calling
Mockito.spy. This change has two advantages - first, it's a tad more
elegant, as it saves the duplicate Mockito.spy calls. Second, and more
importantly, it allows using injected mocks.
Change-Id: I729e078a29929f617636cecf3bf560da303cc207
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/VmSlaPolicyCommandTest.java
1 file changed, 7 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/64688
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I729e078a29929f617636cecf3bf560da303cc207
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roman Mohr <rmohr(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: UpdateStorageServerConnectionCommandTest collections
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: UpdateStorageServerConnectionCommandTest collections
......................................................................
core: UpdateStorageServerConnectionCommandTest collections
Use the specialized Arrays.asList, Collections.singletonList and
Collections.emptyList instead of the general purpose ArrayList to
improve the code's readability and gain an (ever so slight) performance
boost.
Change-Id: I82665768a7a8420c4ee4c57d89aa8325f60d07c5
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/connection/UpdateStorageServerConnectionCommandTest.java
1 file changed, 14 insertions(+), 34 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/64710
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I82665768a7a8420c4ee4c57d89aa8325f60d07c5
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: StorageHandlingCommandBase#getAllRunningVdssInPool
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: StorageHandlingCommandBase#getAllRunningVdssInPool
......................................................................
core: StorageHandlingCommandBase#getAllRunningVdssInPool
This method was only used by the StoragePoolStatusHandler.
This patch moves the method to the class that uses it in order to
decouple a false dependency between it and the command.
Change-Id: I3f07248baf52f0096ac450108600a20801196519
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageHandlingCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/pool/StoragePoolStatusHandler.java
2 files changed, 8 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/64691
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3f07248baf52f0096ac450108600a20801196519
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine[master]: core: UpdateStorageServerConnectionCommandTest local vars
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: UpdateStorageServerConnectionCommandTest local vars
......................................................................
core: UpdateStorageServerConnectionCommandTest local vars
Remove redundant local variables.
Change-Id: I45881ccbeff88a478509d4f6a413158a5420e382
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/connection/UpdateStorageServerConnectionCommandTest.java
1 file changed, 1 insertion(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/64709
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I45881ccbeff88a478509d4f6a413158a5420e382
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months
Change in ovirt-engine-cli[cli_3.6]: cli: Prepare for next release
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: cli: Prepare for next release
......................................................................
cli: Prepare for next release
In preparation for the next release this patch increases the version
number and sets the RPM release number to 0.1.
Change-Id: I1c2adb6ae337868920e0a87571d9f58a8e032714
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M Makefile
M setup.py
2 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65439
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1c2adb6ae337868920e0a87571d9f58a8e032714
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-cli
Gerrit-Branch: cli_3.6
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 3 months