Change in ovirt-engine[ovirt-engine-3.6]: HE: fixed the vm nic changing it's status to unplugged.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: HE: fixed the vm nic changing it's status to unplugged.
......................................................................
HE: fixed the vm nic changing it's status to unplugged.
The fix is to use the nic device id that is reported from the hosted
engine vm when importing it and not to generate a random id.
Change-Id: I0987418d33b61009cbd443e5b6c82872b20242d5
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1311151
Signed-off-by: Jenny Tokar <jtokar(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectBuilderTest.java
2 files changed, 42 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Jenny Tokar: Verified
--
To view, visit https://gerrit.ovirt.org/55214
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0987418d33b61009cbd443e5b6c82872b20242d5
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in jenkins[master]: remove engine-db upgrade from post merged jobs
by eedri@redhat.com
Eyal Edri has submitted this change and it was merged.
Change subject: remove engine-db upgrade from post merged jobs
......................................................................
remove engine-db upgrade from post merged jobs
- we already run engine-upgrade post merged
so no need to duplicate the test.
- Currently keeping 'created' until we'll
decide if to add engine-setup per patch
or move it to STD CI
Change-Id: I7ce242cf4bab07127bfc91a645b2c5c014fbe73c
Signed-off-by: Eyal Edri <eedri(a)redhat.com>
---
M jobs/confs/projects/ovirt-engine/ovirt-engine_upgrade-db.yaml
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me; Ready for review
Eyal Edri: Verified; Ready for merge
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55805
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7ce242cf4bab07127bfc91a645b2c5c014fbe73c
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaro(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-host-deploy[master]: deploy: adding OVIRT_NODE env constant
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: deploy: adding OVIRT_NODE env constant
......................................................................
deploy: adding OVIRT_NODE env constant
Add OVIRT_NODE environment constant.
Change-Id: I0bd6e55d5dfa1eac65217a09ab6c657321e7cb1a
Signed-off-by: emesika <emesika(a)redhat.com>
---
M src/ovirt_host_deploy/constants.py
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Douglas Schilling Landgraf: Looks good to me, but someone else must approve
Sandro Bonazzola: Looks good to me, approved
Eli Mesika: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53532
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0bd6e55d5dfa1eac65217a09ab6c657321e7cb1a
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-host-deploy
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-host-deploy[master]: deploy: rename OVIRT_NODE to OVIRT_VINTAGE_NODE
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: deploy: rename OVIRT_NODE to OVIRT_VINTAGE_NODE
......................................................................
deploy: rename OVIRT_NODE to OVIRT_VINTAGE_NODE
Rename OVIRT_NODE to OVIRT_VINTAGE_NODE in order to add NGN as OVIRT_NODE
Change-Id: If3afd28467bb65b19a8d79f91cb94fa21e68cb6b
Signed-off-by: emesika <emesika(a)redhat.com>
---
M src/ovirt_host_deploy/constants.py
M src/plugins/ovirt-host-deploy/gluster/packages.py
M src/plugins/ovirt-host-deploy/kdump/packages.py
M src/plugins/ovirt-host-deploy/node/detect.py
M src/plugins/ovirt-host-deploy/node/persist.py
M src/plugins/ovirt-host-deploy/tune/tuned.py
M src/plugins/ovirt-host-deploy/vdsm/bridge.py
M src/plugins/ovirt-host-deploy/vdsm/config.py
8 files changed, 28 insertions(+), 12 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Eli Mesika: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53531
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If3afd28467bb65b19a8d79f91cb94fa21e68cb6b
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-host-deploy
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Added permissions on AddProfileBase
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: Added permissions on AddProfileBase
......................................................................
core: Added permissions on AddProfileBase
When adding Disk/Cpu Profile there is always a need to add permissions
on the profile. For that reason, I added an abstract method
addPermissions() that will run each time add profile command is
executed. This method will be implemented by the add Disk/CPU profile
commands with the necessary permissions.
The developer may cancel the automatic call of addPermissions by giving
false in the constructor.
Also, Create/Update/Remove and 'Assign' permissions are given to the
user that created the profile and 'Assign' permissions to everyone else.
Also, this patch changes the way the CPU Profile is added when running
the 'AddClusterCommand'. Instead of adding the CPU Profile directly to
the Database which bypasses all the necessary validations, this patch
uses the 'AddCpuProfileCommand'.
Change-Id: I6f65daf1e46be9521e8541932ce84710175a6c66
Bug-Url: https://bugzilla.redhat.com/1143869
Signed-off-by: Tomer Saban <tsaban(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddClusterCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddPermissionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/profiles/AddCpuProfileCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/profiles/AddDiskProfileCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/profiles/AddProfileCommandBase.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddClusterCommandTest.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/profiles/AddCpuProfileCommandTest.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/profiles/CpuProfileHelperTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/CpuProfileParameters.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/ProfileParametersBase.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/AbstractBackendCpuProfilesResource.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/profiles/CpuProfileBaseModel.java
A packaging/dbscripts/upgrade/04_00_0410_updating_cpu_profile_roles.sql
13 files changed, 427 insertions(+), 21 deletions(-)
Approvals:
Eli Mesika: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Tomer Saban: Verified
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/51636
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6f65daf1e46be9521e8541932ce84710175a6c66
Gerrit-PatchSet: 31
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Phillip Bailey <phbailey(a)redhat.com>
Gerrit-Reviewer: Roman Mohr <rmohr(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-hosted-engine-ha[master]: Fix pyflakes error (image variable shadows imported module)
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Fix pyflakes error (image variable shadows imported module)
......................................................................
Fix pyflakes error (image variable shadows imported module)
Change-Id: I48898ec895ab3bdf3fc56ac1119acab60c940a09
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M ovirt_hosted_engine_ha/lib/upgrade.py
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Martin Sivák: Verified; Looks good to me, approved
Simone Tiraboschi: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55529
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I48898ec895ab3bdf3fc56ac1119acab60c940a09
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: restapi: Update to version 4.0.12 of model and 1.0.7 of meta...
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Update to version 4.0.12 of model and 1.0.7 of metamodel
......................................................................
restapi: Update to version 4.0.12 of model and 1.0.7 of metamodel
This patch updates the engine so that it uses the latest released
versions of the model and the metamodel.
Change-Id: I2d193cf5a80c8bd01099570904e05f2815269fd1
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/pom.xml
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainResource.java
M pom.xml
3 files changed, 27 insertions(+), 34 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55773
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2d193cf5a80c8bd01099570904e05f2815269fd1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in jenkins[master]: ovirt-reports: move master to standard ci
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: ovirt-reports: move master to standard ci
......................................................................
ovirt-reports: move master to standard ci
Change-Id: Ie841938abd8acf44f8a67fde9a9a2d52ec85640b
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M jobs/confs/projects/ovirt/publish-rpms-nightly-master.yaml
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me; Ready for merge
Shirly Radco: Looks good to me
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55739
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie841938abd8acf44f8a67fde9a9a2d52ec85640b
Gerrit-PatchSet: 2
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: IrsProxyData.proceedStorageDomain() - clearer names
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: IrsProxyData.proceedStorageDomain() - clearer names
......................................................................
core: IrsProxyData.proceedStorageDomain() - clearer names
The code of IrsProxyData.proceedStorageDomain() is complex, the confusing
variable names doesn't make it easier to go over it. This patch renames
to variables to hopefuly clearer names.
Change-Id: I6e0c6ebc486a87b89a4bc9072d2e159ba8e0b064
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsProxyData.java
1 file changed, 34 insertions(+), 34 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/55793
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6e0c6ebc486a87b89a4bc9072d2e159ba8e0b064
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: IrsProxyData.proceedStorageDomain() - assignment
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: IrsProxyData.proceedStorageDomain() - assignment
......................................................................
core: IrsProxyData.proceedStorageDomain() - assignment
There's no need for the separation of the decleration/assignment
of domainFromDb/domainPoolMap.
Change-Id: Ic775c145f51fcfaa4542770cb7245792baea90bb
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsProxyData.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/55792
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic775c145f51fcfaa4542770cb7245792baea90bb
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months