Change in ovirt-engine[master]: core: Remove ternary operator usage in RemoveDiskCommand aud...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove ternary operator usage in RemoveDiskCommand audit log
......................................................................
core: Remove ternary operator usage in RemoveDiskCommand audit log
Change the ternary operator usage in RemoveDiskCommand to a more readable
and more maintainable if-else condition in preparation of introducing a
new kind of audit log for disks attached to VMs
Change-Id: I623e64443e7ccd1f81f6c2053c58088f324ca3c6
Related-to: https://bugzilla.redhat.com/1391463
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/RemoveDiskCommand.java
1 file changed, 15 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Verified
Daniel Erez: Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/69464
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I623e64443e7ccd1f81f6c2053c58088f324ca3c6
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Benny Zlotnik <bzlotnik(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[master]: core: Fix bug in discard checks
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: Fix bug in discard checks
......................................................................
core: Fix bug in discard checks
When passing a list of VM disks to validate if their discard value is
legal a map of a disk to its DiskVmElement is created.
The map is created by fetching all of the VM's DiskVmElements and
iterating on them, however, in some cases not all the VM's disk are sent
for the check (one example is deactivated disks) and the map is created
with a null key (since the corresponding disk does not exist in the list
of disks to check) thus causing an NPE later in the flow.
This was fixed by creating a map entry only if there is a disk in the list
corresponding to the DiskVmElement fetched
Change-Id: I5379f3ced6aeeed27e9ab572ff141c0711bd4454
Bug-Url: https://bugzilla.redhat.com/1409995
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/DiskHandler.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/69636
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5379f3ced6aeeed27e9ab572ff141c0711bd4454
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Benny Zlotnik <bzlotnik(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: initial delay before automatic start of vm with lease
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: initial delay before automatic start of vm with lease
......................................................................
core: initial delay before automatic start of vm with lease
The delay is set to 10 monitoring cycles. Currently, the interval between monitoring
cycles is 3 secs and since the network error is triggered by more than 1 thread
it seems that on the average case the initial delay is ~20 sec rather than 30 sec.
Change-Id: Idb3df308a5389db7b74f0a44bb337568a2f4624f
Bug-Url: https://bugzilla.redhat.com/1317429
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
3 files changed, 10 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Passed CI tests
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/69679
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idb3df308a5389db7b74f0a44bb337568a2f4624f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: refactoring in vm analyzer
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: refactoring in vm analyzer
......................................................................
core: refactoring in vm analyzer
1. Remove arguments from isRunSucceeded & isMigrationSucceeded.
2. Rename logVmStatusTransionFromUnknown to auditVmRestoredFromUnknown
3. Extract auditVmRestoredFromUnknown from logVmStatusTransition
Change-Id: I4efa4f007f4288d08c8ae8ce235e4110226cbb91
Bug-Url: https://bugzilla.redhat.com/1317429
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
1 file changed, 10 insertions(+), 10 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/69678
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4efa4f007f4288d08c8ae8ce235e4110226cbb91
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: order VMs by Network doesn't work
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: order VMs by Network doesn't work
......................................................................
core: order VMs by Network doesn't work
commit 166f43c3776a2332ce9cdf377795220fdb17f6e1 removed
usage_network_percent which is needed by the search for sorting VMs by
network usage.
Change-Id: I6ec4807ad8f63a958f43582385fde89c72f9cb54
Bug-Url: https://bugzilla.redhat.com/1400642
Signed-off-by: Shahar Havivi <shaharh(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VmStatisticsDaoImpl.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
M packaging/dbscripts/create_views.sql
A packaging/dbscripts/upgrade/04_01_0690_add_network_usage_to_vm_statistics.sql
M packaging/dbscripts/vms_sp.sql
5 files changed, 20 insertions(+), 0 deletions(-)
Approvals:
Shahar Havivi: Verified
Jenkins CI: Passed CI tests
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/69614
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6ec4807ad8f63a958f43582385fde89c72f9cb54
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: VmDeviceUtils respect allowed duplicate mac addresses.
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: VmDeviceUtils respect allowed duplicate mac addresses.
......................................................................
core: VmDeviceUtils respect allowed duplicate mac addresses.
The check if canPlugInterface of VmDeviceUtils is extended to
respect allowed duplicate mac addresses using macpool.
Change-Id: I880a7c90ae9c2c120ba0bfd7abafd90f8f3f8de8
Bug-Url: https://bugzilla.redhat.com/1404130
Signed-off-by: Dominik Holler <dholler(a)redhat.com>
(cherry picked from commit d527305cc7792fa1809f3ff1978de5f294becda2)
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/VmInterfaceManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/vm/ActivateDeactivateVmNicCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/VmDeviceUtils.java
3 files changed, 27 insertions(+), 13 deletions(-)
Approvals:
Dominik Holler: Verified
Jenkins CI: Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/69618
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I880a7c90ae9c2c120ba0bfd7abafd90f8f3f8de8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Dominik Holler <dholler(a)redhat.com>
Gerrit-Reviewer: Dominik Holler <dholler(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: api: DisksResource - initial size support on add disk
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: api: DisksResource - initial size support on add disk
......................................................................
api: DisksResource - initial size support on add disk
When a sparse image disk is created on block domain it's created with
initial allocation and being extended as needed by the spm (when it's
plugged to a running vm).
Speicifying inital size on the disk creation is useful when there's a
need to create the disk with initial allocated different than the
default value (1gb) for various reasons.
An example would be the image upload, when the data is uploaded to disk
extensions aren't supported - so the disk needs to be created with
initial size that is big enough to contain all the uploaded data.
Change-Id: I463c46a0072076fb0db8ba78a3b587ca34868771
Bug-Url: https://bugzilla.redhat.com/1400296
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/DiskMapper.java
M backend/manager/modules/restapi/types/src/test/java/org/ovirt/engine/api/restapi/types/DiskMapperTest.java
2 files changed, 21 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Jenkins CI: Passed CI tests
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/69605
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I463c46a0072076fb0db8ba78a3b587ca34868771
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: names of not replugged nics as a variable
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: names of not replugged nics as a variable
......................................................................
core: names of not replugged nics as a variable
... rather than a class member. These names should not be part
of the command's state.
Change-Id: I9275e04be429f48f2b1c2e01961a541b2fdb2fe1
Bug-Url: https://bugzilla.redhat.com/1408834
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
1 file changed, 2 insertions(+), 8 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/69670
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9275e04be429f48f2b1c2e01961a541b2fdb2fe1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: proper handling on failure to unplug passthrough nics
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: proper handling on failure to unplug passthrough nics
......................................................................
core: proper handling on failure to unplug passthrough nics
When we cannot unplug passthough network interfaces of a VM that is
to be migrated, runningFailed should be executed to reduce pending
resources, for example.
Change-Id: I0a6a48cba5de6ea8616f07aa0a982fcbef59c4e0
Bug-Url: https://bugzilla.redhat.com/1408834
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
1 file changed, 1 insertion(+), 5 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/69669
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0a6a48cba5de6ea8616f07aa0a982fcbef59c4e0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months
Change in ovirt-engine[ovirt-engine-4.1]: core: cleanup passthrough nics on rerun vm migration
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: core: cleanup passthrough nics on rerun vm migration
......................................................................
core: cleanup passthrough nics on rerun vm migration
When VM migration fails and rerun is triggered, we should first cleanup
the passthrough network interfaces of the host the VM failed to migrate
to and only then to continue with trying to migrate to another host.
Change-Id: Id48b26edeecc20e4d985617f5e5eeb472db4bc51
Bug-Url: https://bugzilla.redhat.com/1408834
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
1 file changed, 2 insertions(+), 0 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/69672
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id48b26edeecc20e4d985617f5e5eeb472db4bc51
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 11 months