Change in ovirt-engine[master]: engine: Use AuditLogDirector directly
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Use AuditLogDirector directly
......................................................................
engine: Use AuditLogDirector directly
The AlertDirecor is a naive wrapper of AuditLogDirector, however, it
doesn't add any value on top of a direct call to AuditLogDirector.
The AlertDirector makes a false assumption that the 'alert' severity is
determined by its logging, however, that is controlled by the severity
of the audit log type.
Therefore, all logging should be done directly by the AuditLogDirector.
Change-Id: Ie2c7cde3822b6fa4b5bf1b7a5c994ef106eeb2ae
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InitVdsOnUpCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/PmHealthCheckManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/SchedulingManager.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AlertDirector.java
4 files changed, 22 insertions(+), 36 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Martin Sivák: Looks good to me, but someone else must approve
Eli Mesika: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76450
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie2c7cde3822b6fa4b5bf1b7a5c994ef106eeb2ae
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Phillip Bailey <phbailey(a)redhat.com>
Gerrit-Reviewer: Roman Mohr <rmohr(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yanir Quinn <yquinn(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Make AlertDirector injectable
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Make AlertDirector injectable
......................................................................
engine: Make AlertDirector injectable
The functionality of the AlertDirector is reduced for removing alerts
from the database. That bean can now be injected simply when required.
Change-Id: I9d41de5b9a4c3163730350fadc45f8afa5e90653
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/PmHealthCheckManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/FenceVdsManualyCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/GlusterUtil.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AlertDirector.java
6 files changed, 35 insertions(+), 17 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76452
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9d41de5b9a4c3163730350fadc45f8afa5e90653
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Use AuditLogableImpl for vm logging
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Use AuditLogableImpl for vm logging
......................................................................
engine: Use AuditLogableImpl for vm logging
With AuditLogableImpl, the properties to be logged can be set while
creating the event log, without any need to access the DB and populate
missing attributes. Since all of the properties for logging host and vm
entities are already available, prefer using this method.
Change-Id: I63fb6c437e5ab035ff3ca4a62ae2e3ffac9207f9
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ClearNonResponsiveVdsVmsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
2 files changed, 8 insertions(+), 7 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76449
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I63fb6c437e5ab035ff3ca4a62ae2e3ffac9207f9
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Remove unused code and simplify host events
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Remove unused code and simplify host events
......................................................................
engine: Remove unused code and simplify host events
There was an incorrect assumption that ${Operation} property is expected
to be passed to the host event log. However, by checking the events
which are expecting for it, the events are being created at place and
not via the VdsCommand.createAlert() method.
Change-Id: I874ebbf99f025b67ffd7a10d2602a41e157dd842
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/VdsNotRespondingTreatmentCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/pm/StartVdsCommandTest.java
3 files changed, 14 insertions(+), 49 deletions(-)
Approvals:
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76448
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I874ebbf99f025b67ffd7a10d2602a41e157dd842
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Rename createAuditLog to create in AuditLogDirector
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Rename createAuditLog to create in AuditLogDirector
......................................................................
engine: Rename createAuditLog to create in AuditLogDirector
The purpose of the AuditLogDirector is to log events to the audit log
table. The method which creates the audit log entries can be simplified
and be named 'create()'.
Change-Id: I1a9cde5b7d635f1f539a1b206684bdd148285629
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirector.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Eli Mesika: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76284
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1a9cde5b7d635f1f539a1b206684bdd148285629
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Reduce visibility of method to private
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Reduce visibility of method to private
......................................................................
engine: Reduce visibility of method to private
The AuditLogDirector.getMessageOrNull(AuditLogType) is used only in the
AuditLogDirector, therefore it should be declard as a private method.
Change-Id: Ifec862f9354d764e81c939f9f4eae0ba1cade6a8
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirector.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Daniel Erez: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76283
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifec862f9354d764e81c939f9f4eae0ba1cade6a8
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Extract message resolving logic from AuditLogDirector
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Extract message resolving logic from AuditLogDirector
......................................................................
engine: Extract message resolving logic from AuditLogDirector
The message resolving can be extracted into its own class, to be
consumed either by the AuditLogDirector or by other clients which
requires that functionality. There is no good reason to require the
entire AuditLogDirector only for that functionality, and since it is a
specific responsibility, it can be stored on its own class.
This patch perfoms a simple refactor and extracts the methods as static
to the new class. Later-on, we can change the nature of this class to be
injected where needed.
Change-Id: I77f6e268e444ae9941d40f8e07e15bd00b98dd8a
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirector.java
A backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/MessageResolver.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/job/ExecutionMessageDirector.java
R backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/MessageResolverTest.java
4 files changed, 117 insertions(+), 106 deletions(-)
Approvals:
Eli Mesika: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76484
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I77f6e268e444ae9941d40f8e07e15bd00b98dd8a
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Remove a redundant method
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Remove a redundant method
......................................................................
engine: Remove a redundant method
A method which is used only once can be removed and be inlined instead.
Change-Id: Id74da5dc542228aa9f07f6154b6a406921aa1b34
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AlertDirector.java
1 file changed, 2 insertions(+), 7 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76447
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id74da5dc542228aa9f07f6154b6a406921aa1b34
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Remove spare injection in AffinityRulesEnforcementMa...
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Remove spare injection in AffinityRulesEnforcementManager
......................................................................
engine: Remove spare injection in AffinityRulesEnforcementManager
There is no need to inject any DAO beans when the logged entity is an
empty one.
Change-Id: Ib9e5b0174a6be0edd785d020156642ad8aa4ccfe
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/AffinityRulesEnforcementManager.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Denis Chaplygin: Looks good to me, but someone else must approve
Martin Sivák: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76279
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib9e5b0174a6be0edd785d020156642ad8aa4ccfe
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Denis Chaplygin <dchaplyg(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Jenny Tokar <jtokar(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Phillip Bailey <phbailey(a)redhat.com>
Gerrit-Reviewer: Roman Mohr <rmohr(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yanir Quinn <yquinn(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months
Change in ovirt-engine[master]: engine: Avoid injection in VdsNotRespondingTreatmentCommand
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Avoid injection in VdsNotRespondingTreatmentCommand
......................................................................
engine: Avoid injection in VdsNotRespondingTreatmentCommand
Since all of the data to be logged is already present at the creating of
the audit-log entity, there is no need to inject any beans to the
AuditLogableBase and it can be replaced with a leaner and more efficient
implementation of the AuditLogable.
Change-Id: I739e7bc4d544477d8f90c7b1c9d9f1e95f59a6d9
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/VdsNotRespondingTreatmentCommand.java
1 file changed, 15 insertions(+), 9 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76276
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I739e7bc4d544477d8f90c7b1c9d9f1e95f59a6d9
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 7 months