Change in ovirt-engine[master]: webadmin: move WebAdmin.css from webadmin to ovirt-brand
by Code Review
>From Greg Sheremeta <gshereme(a)redhat.com>:
Greg Sheremeta has submitted this change and it was merged. ( https://gerrit.ovirt.org/80575 )
Change subject: webadmin: move WebAdmin.css from webadmin to ovirt-brand
......................................................................
webadmin: move WebAdmin.css from webadmin to ovirt-brand
Move WebAdmin.css from webadmin to ovirt-brand to utilize
sass and consolidate css. Change file from css to scss so
it actually runs through the jsass compiler.
Change-Id: Ie6c545534691ee961bff5a5aa90ef9e115e5cdd8
Signed-off-by: Greg Sheremeta <gshereme(a)redhat.com>
---
M frontend/brands/ovirt-brand/src/main/resources/branding.properties
R frontend/brands/ovirt-brand/src/main/sass/WebAdmin.scss
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/webadmin/WebAdmin.gwt.xml
3 files changed, 1 insertion(+), 4 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Greg Sheremeta: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/80575
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie6c545534691ee961bff5a5aa90ef9e115e5cdd8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Scott Dickerson <sdickers(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: engine / branding: introduce sass for css compilation
by Code Review
>From Greg Sheremeta <gshereme(a)redhat.com>:
Greg Sheremeta has submitted this change and it was merged. ( https://gerrit.ovirt.org/80546 )
Change subject: engine / branding: introduce sass for css compilation
......................................................................
engine / branding: introduce sass for css compilation
Introduce sass via libsass [1] / libsass-maven-plugin [2][3],
and move ovirt.brand into a maven project in frontend/brands.
Sass is a css pre-processor that brings us css compression,
allows breaking up css into smaller files (called partials)
without runtime performance penalties, and allows us to
move away from GWT css solutions (whereby css ends up baked
into generated JavaScript).
Follow-up patches will convert our current css files to well-
structured and organized sass files, using partials, variables,
etc.
[1] https://github.com/sass/libsass
[2] https://mvnrepository.com/artifact/com.github.warmuuh/libsass-maven-plugin/
[3] https://github.com/warmuuh/libsass-maven-plugin
libsass is platform-specific, written in C/C++. The Maven
plugin uses jsass [4] to interop with libsass.
jsass uses the "git submodule" feature [5] to pull in libsass code,
effectively avoiding the platform-specific dependency on libsass.
Therefore, jsass is self-contained Sass impl. that contains
all platform-specific libs (Windows .dll, Linux .so, etc.) in
its distributable JAR file.
[4] https://github.com/bit3/jsass
[5] https://github.com/bit3/jsass/blob/develop/.gitmodules
Change-Id: I2bb197c9d4eddf2727179aeec8a358d90e3157fa
Signed-off-by: Greg Sheremeta <gshereme(a)redhat.com>
---
M Makefile
A frontend/brands/ovirt-brand/pom.xml
R frontend/brands/ovirt-brand/src/main/resources/branding.properties
R frontend/brands/ovirt-brand/src/main/resources/common.css
R frontend/brands/ovirt-brand/src/main/resources/external_resources.properties
R frontend/brands/ovirt-brand/src/main/resources/images/dialog/error.png
R frontend/brands/ovirt-brand/src/main/resources/images/favicon-16x16.png
R frontend/brands/ovirt-brand/src/main/resources/images/favicon-32x32.png
R frontend/brands/ovirt-brand/src/main/resources/images/favicon.ico
R frontend/brands/ovirt-brand/src/main/resources/images/oVirt_About_BG_Flat_Image.png
R frontend/brands/ovirt-brand/src/main/resources/images/oVirt_Banner_solid.png
R frontend/brands/ovirt-brand/src/main/resources/images/oVirt_Landing_Bottom_Left_Corner.png
R frontend/brands/ovirt-brand/src/main/resources/images/oVirt_Landing_Top_Right_Corner.png
R frontend/brands/ovirt-brand/src/main/resources/images/oVirt_Logo.png
R frontend/brands/ovirt-brand/src/main/resources/images/ovirt_header_logo.png
R frontend/brands/ovirt-brand/src/main/resources/images/ovirt_middle_logo_name.png
R frontend/brands/ovirt-brand/src/main/resources/messages.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_de_DE.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_es_ES.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_fr_FR.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_it_IT.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_ja_JP.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_ko_KR.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_pt_BR.properties
R frontend/brands/ovirt-brand/src/main/resources/messages_zh_CN.properties
R frontend/brands/ovirt-brand/src/main/resources/ovirt-patternfly-compat.css
R frontend/brands/ovirt-brand/src/main/resources/ovirt.css
R frontend/brands/ovirt-brand/src/main/resources/patternfly-ovirt.css
R frontend/brands/ovirt-brand/src/main/resources/resources.properties
R frontend/brands/ovirt-brand/src/main/resources/web_admin.css
R frontend/brands/ovirt-brand/src/main/resources/welcome_page.template
R frontend/brands/ovirt-brand/src/main/resources/welcome_style.css
A frontend/brands/pom.xml
M frontend/pom.xml
M ovirt-engine.spec.in
M pom.xml
36 files changed, 100 insertions(+), 6 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Greg Sheremeta: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/80546
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2bb197c9d4eddf2727179aeec8a358d90e3157fa
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Scott Dickerson <sdickers(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-log-collector[master]: inventory: improve how we display urls
by Code Review
>From Douglas Schilling Landgraf <dougsland(a)redhat.com>:
Douglas Schilling Landgraf has submitted this change and it was merged. ( https://gerrit.ovirt.org/80723 )
Change subject: inventory: improve how we display urls
......................................................................
inventory: improve how we display urls
Instead of show full urls, use related words.
Example: instead of full bugzilla url, use bz#NUMBER_ID
Change-Id: I19787acb9dd6f29ef889a27a55841d4dabbfd002
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/produceReport/pre-upgrade-checks
1 file changed, 12 insertions(+), 14 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/80723
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I19787acb9dd6f29ef889a27a55841d4dabbfd002
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: vmSnapshotListModel#setItems computeIfAbsent
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80713 )
Change subject: webadmin: vmSnapshotListModel#setItems computeIfAbsent
......................................................................
webadmin: vmSnapshotListModel#setItems computeIfAbsent
Use Java 8's Map#computeIfAbsent method instead of reimplementing its
logic.
Change-Id: Idd51cd755eb80fd9ec9a38a66f6014606687a813
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 1 insertion(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80713
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idd51cd755eb80fd9ec9a38a66f6014606687a813
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: VmSnapshotListModel streams for statuses
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80709 )
Change subject: webadmin: VmSnapshotListModel streams for statuses
......................................................................
webadmin: VmSnapshotListModel streams for statuses
Use Java 8 streams for filtering snapshots by their status in order
to clean up the code and make it easier to maintain.
Change-Id: Id0bb9d223a237d7268db409797d024946544660c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 3 insertions(+), 33 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80709
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id0bb9d223a237d7268db409797d024946544660c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: Inline VmSnapshotListModel#getIsStateless
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80710 )
Change subject: webadmin: Inline VmSnapshotListModel#getIsStateless
......................................................................
webadmin: Inline VmSnapshotListModel#getIsStateless
Remove a useless method and inline its implementation to make the
code easier to read.
Change-Id: If5c1af305478488e753f7f582b0661f08711f1ab
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 1 insertion(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80710
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If5c1af305478488e753f7f582b0661f08711f1ab
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: VmSnapshotListModel PREVIEW snapshot checking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80711 )
Change subject: webadmin: VmSnapshotListModel PREVIEW snapshot checking
......................................................................
webadmin: VmSnapshotListModel PREVIEW snapshot checking
In VmSnapshotListModel#setItems, every iteration of the loop checks
if there's a snapshot which has the PREVIEW type. However, as the
snapshots do not change throughout the loop, it could be checked only
once, before the loop. This would both [arguably] clean up the code,
but also provide a slight performance enhancement.
Change-Id: I7aa3c21f4e5af89abfa0fb5413510785c73c1d5f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80711
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7aa3c21f4e5af89abfa0fb5413510785c73c1d5f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: Inline VmSnapshotListModel#getInType
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80712 )
Change subject: webadmin: Inline VmSnapshotListModel#getInType
......................................................................
webadmin: Inline VmSnapshotListModel#getInType
Remove a useless method and replace it with a oneliner stream call
which is easier to understand and maintain.
Change-Id: Ie69597917307e8a8c2faade0598a24445a011483
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 1 insertion(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80712
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie69597917307e8a8c2faade0598a24445a011483
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: VmSnapshotListModel diamond operator
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80705 )
Change subject: webadmin: VmSnapshotListModel diamond operator
......................................................................
webadmin: VmSnapshotListModel diamond operator
Change-Id: I6dcc6dcb3a8f864dfe992be0f2a3301c96468311
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80705
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6dcc6dcb3a8f864dfe992be0f2a3301c96468311
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months
Change in ovirt-engine[master]: webadmin: VmSnapshotListModel sorting
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged. ( https://gerrit.ovirt.org/80706 )
Change subject: webadmin: VmSnapshotListModel sorting
......................................................................
webadmin: VmSnapshotListModel sorting
Use the optimized ArrayList#sort introduced in Java 8 instead of
Collections#sort.
Change-Id: Iddea2be9c24c76ce1a72eea43fefd0e2d03e54e5
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/80706
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iddea2be9c24c76ce1a72eea43fefd0e2d03e54e5
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 4 months