Change in ovirt-engine[master]: core: BaseIscsiBondCommand lambdas
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: BaseIscsiBondCommand lambdas
......................................................................
core: BaseIscsiBondCommand lambdas
Replaced BaseIscsiBondCommand's usage of LinqUtils with Java 8's
built-in labmda capabilities.
Performance is improved by iterating the map's entrySet() instead of
iterating the keySet() and calling get(key).
Change-Id: I38055254de67cff1e962d1265592fce774cd9c2f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/BaseIscsiBondCommand.java
1 file changed, 4 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/48559
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I38055254de67cff1e962d1265592fce774cd9c2f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: RemoveStoragePoolCommand labmdas
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RemoveStoragePoolCommand labmdas
......................................................................
core: RemoveStoragePoolCommand labmdas
Removed LinqUtils and replaced with the modern, built-in Java 8 syntax.
Change-Id: I2cfcb83617b9ff492d60d5c0010d7aa76c1048b9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/RemoveStoragePoolCommand.java
1 file changed, 6 insertions(+), 16 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48558
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2cfcb83617b9ff492d60d5c0010d7aa76c1048b9
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: FenceVdsManualyCommand early return
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: FenceVdsManualyCommand early return
......................................................................
core: FenceVdsManualyCommand early return
Use the early return idiom in FenceVdsManualyCommand#canDoAction() to
reduce code and improve readability.
Change-Id: I8d412524f1bfc1363d205d7d563e7322a1cdd166
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/FenceVdsManualyCommand.java
1 file changed, 7 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48561
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8d412524f1bfc1363d205d7d563e7322a1cdd166
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: FenceVdsManualyCommand finding master domain
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: FenceVdsManualyCommand finding master domain
......................................................................
core: FenceVdsManualyCommand finding master domain
Improve performance by querying the master domain from the database
instead of querying all the domains in the pool and filtering the master
domain in-memory.
Change-Id: I552944050f515f5f2f0bb214a6d0e98a9b8c6d9a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/FenceVdsManualyCommand.java
1 file changed, 2 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48560
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I552944050f515f5f2f0bb214a6d0e98a9b8c6d9a
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: RefreshLunsSizeCommand linq usage
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RefreshLunsSizeCommand linq usage
......................................................................
core: RefreshLunsSizeCommand linq usage
Replace the usage of LinqUtils.first() with the Java 8 built in
streaming API, as part of the attempt to remove LinqUtils from the
codebase.
Change-Id: I1e062c351a4cdbb8bff243ac3395942f92bc7f0c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/RefreshLunsSizeCommand.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/48568
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1e062c351a4cdbb8bff243ac3395942f92bc7f0c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: RefreshLunsSizeCommand method args
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RefreshLunsSizeCommand method args
......................................................................
core: RefreshLunsSizeCommand method args
Removed unused parameter from checkLunsInStorageDomain.
Change-Id: I4f04b4009651968c05449558c2b8d98724c4d0fb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/RefreshLunsSizeCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/48569
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4f04b4009651968c05449558c2b8d98724c4d0fb
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: detaching master domain cleanup
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: detaching master domain cleanup
......................................................................
core: detaching master domain cleanup
The LinqUtils call in
StorageDomainCommandBase#isDetachAllowed(boolean) is useless - it
retrieves a domain from the pool that has the same ID of the domain
being removed (i.e., the exact same domain) and an "Active" status.
The previous call to checkStorageDomainStatus in canDetachDomain
ensures its status will be "Maintenance" or "Inactive", so it's known
to return an null.
Since its result is known, it can be skipped, and save a relatively
expensive database call.
Change-Id: Iff87f89170d555d98ec071b42e46f3dff1883b1b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageDomainCommandBase.java
1 file changed, 3 insertions(+), 19 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/48155
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff87f89170d555d98ec071b42e46f3dff1883b1b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: StorageDomainCommandBase early return
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: StorageDomainCommandBase early return
......................................................................
core: StorageDomainCommandBase early return
Use the early retun idiom for better readability.
Change-Id: Iba20a266e5656556223d79a06bc8a2ce631a834b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageDomainCommandBase.java
1 file changed, 10 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/48156
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iba20a266e5656556223d79a06bc8a2ce631a834b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: core: fix remove vm from export domain
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: fix remove vm from export domain
......................................................................
core: fix remove vm from export domain
The injection of BackendInternal broke import from export domain.
The problem was that in the constructor of RemoveVmCommand we called
getVm() that invokes a query to get the VM from the export domain.
However, BackendInternal is not injected at this stage so NPE is
thrown. The solution is to extract the initialization code in
RemoveVmCommand into the 'init' method that is called after the
object is constructed, including its injected fields.
Change-Id: Ieb4cd5f4b301d73a996ad4acc505fd8bb42e29fd
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVmCommand.java
1 file changed, 8 insertions(+), 4 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/48576
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ieb4cd5f4b301d73a996ad4acc505fd8bb42e29fd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months
Change in ovirt-engine[master]: engine: add missing 'NETWORK_MAC_ADDRESS_IN_USE' entry to Ap...
by alkaplan@redhat.com
Alona Kaplan has submitted this change and it was merged.
Change subject: engine: add missing 'NETWORK_MAC_ADDRESS_IN_USE' entry to AppError.java
......................................................................
engine: add missing 'NETWORK_MAC_ADDRESS_IN_USE' entry to AppError.java
It was removed by mistake in patch-
I06248e23e32b7ca2e7f3397e8c0e28e24eb20bf5
Change-Id: Ifaf72f04194bf255d1b8353082f837dc98bbcd4e
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48440
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifaf72f04194bf255d1b8353082f837dc98bbcd4e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 2 months