Change in ovirt-engine[master]: core: FixturesTest closing resources
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: FixturesTest closing resources
......................................................................
core: FixturesTest closing resources
Used the try-with-resource syntax to ensure that fixturesStream is
properly closed when the setUp() finishes.
This patch solves the Coverity defect CID#1348247.
Change-Id: I7b6702a4aa3e888f78f86fe241172bc25e68d3c6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/FixturesTest.java
1 file changed, 8 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Martin Mucha: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52405
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7b6702a4aa3e888f78f86fe241172bc25e68d3c6
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: VmAnalyzer#proceedVmBeforeDeletion null check
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: VmAnalyzer#proceedVmBeforeDeletion null check
......................................................................
core: VmAnalyzer#proceedVmBeforeDeletion null check
Added null check on vdsmVm to solve Coverity issue CID#1349409.
Change-Id: Ic3e424e30551e45b0d9956c9207c50365f55f439
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmAnalyzer.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52391
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic3e424e30551e45b0d9956c9207c50365f55f439
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: AddVmCommand redundant return removed
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddVmCommand redundant return removed
......................................................................
core: AddVmCommand redundant return removed
Change-Id: If757072404492f01f5ff70d4dd80155871ec0c85
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52243
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If757072404492f01f5ff70d4dd80155871ec0c85
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GlusterSnapshotSyncJobTest ArgumentMatchers
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterSnapshotSyncJobTest ArgumentMatchers
......................................................................
core: GlusterSnapshotSyncJobTest ArgumentMatchers
Removed redundant ArgumentMatchers that were no more than calls to
equals(Object).
Change-Id: If378e557a8dc58ec0b1d08e2772e00a3bedc1a47
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GlusterSnapshotSyncJobTest.java
1 file changed, 3 insertions(+), 39 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52284
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If378e557a8dc58ec0b1d08e2772e00a3bedc1a47
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GetUserVmsByUserIdAndGroupsQueryTest functional API
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetUserVmsByUserIdAndGroupsQueryTest functional API
......................................................................
core: GetUserVmsByUserIdAndGroupsQueryTest functional API
Use Java 8's functional API instead of an explicit anonymous
implementation, as per the project's standards.
Change-Id: I803d4f4139a3f7b238b94a3551a6ec3195ce64c5
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetUserVmsByUserIdAndGroupsQueryTest.java
1 file changed, 5 insertions(+), 11 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52280
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I803d4f4139a3f7b238b94a3551a6ec3195ce64c5
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GetUserVmsByUserIdAndGroupsQueryTest doNothing()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetUserVmsByUserIdAndGroupsQueryTest doNothing()
......................................................................
core: GetUserVmsByUserIdAndGroupsQueryTest doNothing()
Used Mockito.doNothing() instead of an useless, empty implementation of
an Answer with doAnswer(Answer) to improve the code's readability.
Change-Id: I76f90d2db0c5e5f39297dd8e3b1b6ba8d83c6fc6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetUserVmsByUserIdAndGroupsQueryTest.java
1 file changed, 1 insertion(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52279
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I76f90d2db0c5e5f39297dd8e3b1b6ba8d83c6fc6
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: CreateOvfVolumeForStorageDomainCommand Arrays.asList
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: CreateOvfVolumeForStorageDomainCommand Arrays.asList
......................................................................
core: CreateOvfVolumeForStorageDomainCommand Arrays.asList
Replace single argument Arrays.asList calls with the better performing
Collections.singletonList.
Change-Id: I34539bcf8e426cd6e597852ea3b736afb62798fe
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ovfstore/CreateOvfVolumeForStorageDomainCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/52273
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I34539bcf8e426cd6e597852ea3b736afb62798fe
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GetGlusterVolumeRebalanceStatusQueryTest members
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterVolumeRebalanceStatusQueryTest members
......................................................................
core: GetGlusterVolumeRebalanceStatusQueryTest members
Converted members to local variables where possible in order to improve
readability and reduce memory footprint.
Change-Id: Iea2aeffb2387ea4b74058c8e270e290770b3dcc8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeRebalanceStatusQueryTest.java
1 file changed, 4 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52269
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iea2aeffb2387ea4b74058c8e270e290770b3dcc8
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: GetGlusterVolumeProfileInfoQueryTest boxing
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterVolumeProfileInfoQueryTest boxing
......................................................................
core: GetGlusterVolumeProfileInfoQueryTest boxing
Removed explicit boxing to improve the code's performance and
readability.
Change-Id: I9e38eda2d7fc97d67b87ee69db7dec3e34e7fb96
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeProfileInfoQueryTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52268
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9e38eda2d7fc97d67b87ee69db7dec3e34e7fb96
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: ClusterListModel#addHost logic
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: ClusterListModel#addHost logic
......................................................................
webadmin: ClusterListModel#addHost logic
Simplified logic by removing a check of a boolean variable that is
known to be true in the first iteration. Note that the loop breaks after
this iteration, so there's no way to enter the loop with a false value.
Change-Id: Idb60a461ffc6677844e9b4f61c7894c1c6c107d1
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52251
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idb60a461ffc6677844e9b4f61c7894c1c6c107d1
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months