Change in ovirt-engine[master]: restapi: BackendOpenStackVolumeTypeResource stream
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: restapi: BackendOpenStackVolumeTypeResource stream
......................................................................
restapi: BackendOpenStackVolumeTypeResource stream
Use Java 8's streaming API instead of the cumbersome CollectionUtils in
order to clean up the code and make it easier to read and understand.
Change-Id: I6a31c694436bb25774ddc2cf26bb4cca06462577
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/openstack/BackendOpenStackVolumeTypeResource.java
1 file changed, 8 insertions(+), 10 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53017
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6a31c694436bb25774ddc2cf26bb4cca06462577
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: CinderDisksValidator streaming API
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: CinderDisksValidator streaming API
......................................................................
core: CinderDisksValidator streaming API
Replaced the cumbersome org.apache.commons.collections.Predicate usage
with a cleaner, straight-forward built in streaming API.
Note that this change is made possible by upgrading the Spring version
we use done in patch 38d542e9b170bda3966d58a283ffb96014d666d1.
Change-Id: I54ec00164f9ed22431848411f2502e9ae98f67a9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/storage/CinderDisksValidator.java
1 file changed, 3 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53009
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I54ec00164f9ed22431848411f2502e9ae98f67a9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: StorageHelperBase streaming API
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: StorageHelperBase streaming API
......................................................................
core: StorageHelperBase streaming API
Replaced the cumbersome org.apache.commons.collections.Predicate usage
with a cleaner, straight-forward built in streaming API.
Note that this change is made possible by upgrading the Spring version
we use done in patch 38d542e9b170bda3966d58a283ffb96014d666d1.
Change-Id: I584772438683436f00dec17bfecd31d9deed577f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/connection/StorageHelperBase.java
1 file changed, 2 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Ala Hino: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53008
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I584772438683436f00dec17bfecd31d9deed577f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: StorageDomainDaoImpl streaming API
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: StorageDomainDaoImpl streaming API
......................................................................
core: StorageDomainDaoImpl streaming API
With the upgrade of the Spring framework to 4.2.4 (in commit
38d542e9b170bda3966d58a283ffb96014d666d1), the DAO tests now
support Java 8 bytecode, allowing us to remove the ugly hack introduced
in patch 2371f34b0904041e8c1a14ba4157d4c7f162a09d and replace it with a
clean, readable, usage of the streaming API.
Change-Id: Iae6ab3c499dd31d4be66fcf697c4857a83ae75b8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/StorageDomainDaoImpl.java
1 file changed, 1 insertion(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52958
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iae6ab3c499dd31d4be66fcf697c4857a83ae75b8
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest streaming
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest streaming
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest streaming
Replace the outdated of Apache Commons Collections' Predicate with
modern Java 8 streaming APIs to improve the code's readability and make
it more standard.
Note that this patch also offers a slight theoretical performance
improvement in case the test fails, as noneMatch returns early on the
first match, while filtering using Collections.select has to iterate the
entire list, regardless of matches.
Change-Id: I8b2d54f6e01eab2e7cf02d5a4a785ab728de04a8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 2 insertions(+), 9 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53024
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8b2d54f6e01eab2e7cf02d5a4a785ab728de04a8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest asserts
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest asserts
Fixed the order of arguments in the assertEquals calls to produce proper
error messages in case the test ever fails.
Change-Id: Ieb23fdc8bfc8d4be474960c648c4f38cad593381
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53023
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ieb23fdc8bfc8d4be474960c648c4f38cad593381
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest lists
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest lists
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest lists
Remove redundant creation of ArrayLists and use the appropriate
unmodifyable implementations instead.
Change-Id: I8919423eb0dd312aa85bb539a99bb0b7845eb8fa
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53022
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8919423eb0dd312aa85bb539a99bb0b7845eb8fa
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest members
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest members
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest members
Convert members to local variables in order to reduce their scope and
make the code more intuitive to read.
Change-Id: I3a6c5d75206141102ac840a6ad199d1e1554ae44
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 4 insertions(+), 12 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53020
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3a6c5d75206141102ac840a6ad199d1e1554ae44
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest generics
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest generics
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest generics
Use generics instead of raw classes in order to remove warnings, improve
readability and prevent potential bugs when modifying the code in the
future.
Change-Id: I18098dbed27612470410ca2f1c91cca188e381f0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53021
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I18098dbed27612470410ca2f1c91cca188e381f0
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest mocks
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetAllDiskSnapshotsByStorageDomainIdQueryTest mocks
......................................................................
core: GetAllDiskSnapshotsByStorageDomainIdQueryTest mocks
Use the @Mock annotation instead of explicitly calling Mockito.mock.
This clears up the code a bit and makes it easier for the reader to
focus on the logic of the test.
Change-Id: I3d61348726b08b47c0c1bbce0780b5a30cadbd75
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/GetAllDiskSnapshotsByStorageDomainIdQueryTest.java
1 file changed, 3 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53019
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3d61348726b08b47c0c1bbce0780b5a30cadbd75
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months