Change in ovirt-engine[master]: core: MTUValidator assertions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MTUValidator assertions
......................................................................
core: MTUValidator assertions
Use readable assertTrue and assertFalse assertions on isEmpty() instead
of a hard to understand comparison on the size().
Change-Id: I65072ee7e68a292ee556bbdd93a9449f590e6771
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/MTUValidatorTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44518
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I65072ee7e68a292ee556bbdd93a9449f590e6771
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: NoRepetitiveStaticIpInListConstraintTest modifiers
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: NoRepetitiveStaticIpInListConstraintTest modifiers
......................................................................
core: NoRepetitiveStaticIpInListConstraintTest modifiers
Made private utility methods and classes static, as per proper Java
conventions.
Change-Id: I062190a2b8c1ea3e3fb59598badf463aa6bb1ca9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/validation/NoRepetitiveStaticIpInListConstraintTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44516
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I062190a2b8c1ea3e3fb59598badf463aa6bb1ca9
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: MTUValidatorTest modifiers
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MTUValidatorTest modifiers
......................................................................
core: MTUValidatorTest modifiers
Made private utility classes static, as per proper Java conventions.
Change-Id: I8f4009cbe5f93e65e33a57b1f5b75c4cec447071
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/MTUValidatorTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44517
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8f4009cbe5f93e65e33a57b1f5b75c4cec447071
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: TimeoutBaseTest.TestTimeoutBase modifier
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TimeoutBaseTest.TestTimeoutBase modifier
......................................................................
core: TimeoutBaseTest.TestTimeoutBase modifier
Made TestTimeoutBase static, as it doesn't share any information with a
specific instance of its enclosing TimeoutBaseTest.
Change-Id: I77b75a71b7c99d639d65e9c3817741915c672f7b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/TimeoutBaseTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/44515
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I77b75a71b7c99d639d65e9c3817741915c672f7b
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: GetNextAvailableDiskAliasNameByVMIdQueryTest modifiers
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetNextAvailableDiskAliasNameByVMIdQueryTest modifiers
......................................................................
core: GetNextAvailableDiskAliasNameByVMIdQueryTest modifiers
Made constant strings and private utility methods static, as per
proper Java conventions.
Change-Id: I8c5e4ce225eae5ce3f64617db17c2115ebc78218
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetNextAvailableDiskAliasNameByVMIdQueryTest.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44514
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8c5e4ce225eae5ce3f64617db17c2115ebc78218
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: webadmin: ExecuteNetworkCommandInNetworkOperationTest
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: ExecuteNetworkCommandInNetworkOperationTest
......................................................................
webadmin: ExecuteNetworkCommandInNetworkOperationTest
Made private members static, as per proper Java conventions.
Change-Id: I2cc96d4919b123fbbb7998668aece5ccf663672b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/test/java/org/ovirt/engine/ui/uicommonweb/models/hosts/network/ExecuteNetworkCommandInNetworkOperationTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44526
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2cc96d4919b123fbbb7998668aece5ccf663672b
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: RpmVersionUtilsTest#testISplitRpm() asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RpmVersionUtilsTest#testISplitRpm() asserts
......................................................................
core: RpmVersionUtilsTest#testISplitRpm() asserts
Rewrote RpmVersionUtilsTest#testISplitRpm() to use the modern
assertArraysEquals(Object[], Object[]) to make easier to read and
understand.
Change-Id: I4c6df449e25de971c822f369c8b8566e0460df24
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/RpmVersionUtilsTest.java
1 file changed, 3 insertions(+), 5 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/44525
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4c6df449e25de971c822f369c8b8566e0460df24
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: Remove useless RpmVersionUtilsTest asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove useless RpmVersionUtilsTest asserts
......................................................................
core: Remove useless RpmVersionUtilsTest asserts
Removed asserts from negative test cases that throw exceptions. In these
methods the splitRpmToParts call does not return any value, it throws an
exception. As such, the assertEquals call is useless, and just adds
confusion to the test.
Change-Id: I652b29247139a8f961dfc5837e0ab4da2dcbbb63
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/RpmVersionUtilsTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/44524
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I652b29247139a8f961dfc5837e0ab4da2dcbbb63
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: RpmVersionTest asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RpmVersionTest asserts
......................................................................
core: RpmVersionTest asserts
Cleaned up asserts in RpmVersionTest to use assertEquals and
assertNotEquals with the right order of arguments to make the test
easier to read and understand.
Change-Id: Ia733f266d07c341e09b36b40defdc11f21d4f7ac
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/compat/src/test/java/org/ovirt/engine/core/compat/RpmVersionTest.java
1 file changed, 32 insertions(+), 33 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/44523
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia733f266d07c341e09b36b40defdc11f21d4f7ac
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: VmNetworkInterfaceValidationTest modifiers
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: VmNetworkInterfaceValidationTest modifiers
......................................................................
core: VmNetworkInterfaceValidationTest modifiers
Made private utility classes and methods static, as per proper Java
conventions.
Change-Id: I71c5428e770ccfddceae05ea0537d8668442bb19
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/businessentities/network/VmNetworkInterfaceValidationTest.java
1 file changed, 11 insertions(+), 11 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/44521
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I71c5428e770ccfddceae05ea0537d8668442bb19
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months